summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/tudor-volumed/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/tudor-volumed/files')
-rw-r--r--media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch b/media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch
new file mode 100644
index 000000000000..73a5090665e7
--- /dev/null
+++ b/media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch
@@ -0,0 +1,43 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue May 29 11:49:50 UTC 2012
+Subject: build system
+
+respect LDFLAGs, CXXFLAGs and CXX
+
+--- Makefile
++++ Makefile
+@@ -3,12 +3,12 @@
+ all: $(BIN)
+
+ $(BIN): $(OBJECTS)
+- $(CXX) $(CXXFLAGS) $^ -o $(BIN) $(LIBS) -ggdb
++ $(CXX) $(CXXFLAGS) $^ -o $(BIN) $(LDFLAGS) $(LIBS)
+
+ %.o: %.cpp
+- $(CXX) $(CXXFLAGS) -c $^ -o $@ -ggdb
++ $(CXX) $(CXXFLAGS) -c $^ -o $@
+
+ clean:
+ rm -f $(BIN) $(OBJECTS)
+
+-.PHONY: clean all
+\ No newline at end of file
++.PHONY: clean all
+--- config.mk
++++ config.mk
+@@ -2,7 +2,7 @@
+
+ NAME := tudor-volumed
+ OS := $(shell uname -o)
+-CXX := gcc
++CXX ?= gcc
+
+ LIBS := -lX11 -lstdc++
+ BIN := $(NAME)
+@@ -17,4 +17,4 @@
+ ifdef OSSLIBDIR
+ CXXFLAGS += -DUSE_OSS -I${OSSLIBDIR}/include/sys
+ OBJECTS += ossmixer.o
+-endif
+\ No newline at end of file
++endif