summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-06-19 10:30:03 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-06-19 10:30:03 +0200
commitd25c07f99b35d73520d1ea19c4bee11024874438 (patch)
treede240b37ae1a30a44ec69ca316f20f8f30d2ab5c /media-sound/qsynth
parentmedia-sound/qjackctl: bump to 1.0.0 (diff)
downloadgentoo-d25c07f99b35d73520d1ea19c4bee11024874438.tar.gz
gentoo-d25c07f99b35d73520d1ea19c4bee11024874438.tar.bz2
gentoo-d25c07f99b35d73520d1ea19c4bee11024874438.zip
media-sound/qsynth: bump to 1.0.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-1.0.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 868af56b5205..879a0b53329d 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.9.91.tar.gz 334833 BLAKE2B 057ebf72aab4ea811046fede9df42ef7ccb7b98018544397e67212d694d7d798761340114a6609c230062791c81050f11c77348674008e09b1c1f9a28ea27f47 SHA512 0749195078e223ae7e42f2fc7d7f435bc174290f9d018ed01ec27088599f5e1e39739b20aa1233368e45336fb6ff74c9f634942e34543a7405f02749dc76446b
+DIST qsynth-1.0.0.tar.gz 337358 BLAKE2B 40e2b6aacf21eb17169b0899f1b089cb2869295fd5a3b87a4d0e8d7632bce8518ce4d2dc22dafa2c9d4fafe0211c90b9729432a7407bd35f8237c357ce1cb897 SHA512 9533cb425345a83ed9695917885cba52278035c2a6f7b824981b9ec5033b5d61b7ac050cc7e516a6aa7f4ff76e29eb29089a93a727294e7a6a1e5fb631720ea4
diff --git a/media-sound/qsynth/qsynth-1.0.0.ebuild b/media-sound/qsynth/qsynth-1.0.0.ebuild
new file mode 100644
index 000000000000..496e8129a1ca
--- /dev/null
+++ b/media-sound/qsynth/qsynth-1.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="https://downloads.sourceforge.net/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio qt6"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ qt6? ( dev-qt/qttools:6[linguist] )
+ !qt6? ( dev-qt/linguist-tools:5 )
+"
+DEPEND="
+ qt6? (
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtsvg:6
+ )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_QT6=$(usex qt6 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth org.rncbc.qsynth
+}