summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/poc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/poc')
-rw-r--r--media-sound/poc/Manifest1
-rw-r--r--media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch9
-rw-r--r--media-sound/poc/files/poc-0.4.1-file-perms.patch9
-rw-r--r--media-sound/poc/metadata.xml5
-rw-r--r--media-sound/poc/poc-0.4.1.ebuild39
5 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/poc/Manifest b/media-sound/poc/Manifest
new file mode 100644
index 000000000000..d570bcacf14a
--- /dev/null
+++ b/media-sound/poc/Manifest
@@ -0,0 +1 @@
+DIST poc-0.4.1.tar.gz 114875 RMD160 f7981920993742aeed20aa6000dfd53c4b9f8ffc SHA1 b2d210886b04544a33ed863927b8eadcf706e186 SHA256 a8f8be5281b80f9bb1dd0d330ec59e608d557351f6e6ad5b3d14932f7b952d29
diff --git a/media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch b/media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch
new file mode 100644
index 000000000000..f0957a1ca292
--- /dev/null
+++ b/media-sound/poc/files/poc-0.4.1-fec-pkt-prototype.patch
@@ -0,0 +1,9 @@
+sync prototypes between the header and source
+
+--- fec-pkt.c
++++ fec-pkt.c
+@@ -68,3 +68,3 @@
+ **/
+-int fec_pkt_read(fec_pkt_t *pkt, int fd) {
++ssize_t fec_pkt_read(fec_pkt_t *pkt, int fd) {
+ assert(pkt != NULL);
diff --git a/media-sound/poc/files/poc-0.4.1-file-perms.patch b/media-sound/poc/files/poc-0.4.1-file-perms.patch
new file mode 100644
index 000000000000..ee23d90ab82b
--- /dev/null
+++ b/media-sound/poc/files/poc-0.4.1-file-perms.patch
@@ -0,0 +1,9 @@
+Creating mp3 files with u+x attributes is just silly
+
+--- file.c
++++ file.c
+@@ -136,3 +136,3 @@
+ file->fd = open(filename, O_WRONLY | O_CREAT | O_TRUNC,
+- S_IRWXU | S_IRGRP | S_IROTH);
++ S_IRUSR|S_IWUSR | S_IRGRP | S_IROTH);
+
diff --git a/media-sound/poc/metadata.xml b/media-sound/poc/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/poc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/poc/poc-0.4.1.ebuild b/media-sound/poc/poc-0.4.1.ebuild
new file mode 100644
index 000000000000..83a3b0f219f9
--- /dev/null
+++ b/media-sound/poc/poc-0.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="mp3 and ogg streamer (include mp3cue and mp3cut)"
+HOMEPAGE="http://www.bl0rg.net/software/poc"
+SRC_URI="http://www.bl0rg.net/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/flex
+ sys-devel/bison"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^CFLAGS/s:-O2::' \
+ -e '/^PREFIX/s:/local::' \
+ Makefile
+ epatch "${FILESDIR}"/${P}-fec-pkt-prototype.patch
+ epatch "${FILESDIR}"/${P}-file-perms.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc README TODO
+}