summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/normalize/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/normalize/files')
-rw-r--r--media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch b/media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch
new file mode 100644
index 000000000000..09f211cdfb66
--- /dev/null
+++ b/media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch
@@ -0,0 +1,55 @@
+Use pkgconfig to check for audiofile since the audiofile-config script was
+removed from >=audiofile-0.3.0.
+
+--- normalize-0.7.7/configure.ac.orig
++++ normalize-0.7.7/configure.ac
+@@ -248,33 +248,16 @@
+
+
+ dnl *** Stuff for audiofile library ***
+-dnl v0.2.1 and before have bugs with 24-bit LE files
+-AM_PATH_AUDIOFILE([ 0.2.2 ], [ have_audiofile=true ])
+-dnl AC_CHECK_LIB(audiofile, afSetVirtualSampleFormat, have_audiofile=true)
++AC_ARG_WITH(audiofile, AC_HELP_STRING([--with-audiofile],
++ [use the audiofile library (default yes)]))
+ AH_TEMPLATE([USE_AUDIOFILE],
+ [Define if you want to use the audiofile library.])
+-AC_ARG_WITH(audiofile,
+- AC_HELP_STRING([--with-audiofile],
+- [use the audiofile library (default yes)]),
+- [ case "$withval" in
+- no) with_audiofile=false ;;
+- *) with_audiofile=true ;;
+- esac ])
+
+-use_audiofile=false
+-if test x$with_audiofile != xfalse; then
+- if test x$have_audiofile = xtrue; then
+- AC_DEFINE(USE_AUDIOFILE)
+- use_audiofile=true
+-dnl AUDIOFILELIBS="-laudiofile"
+- elif test x$with_audiofile = xtrue; then
+- AC_MSG_ERROR([--with-audiofile specified, but audiofile library not found])
+- fi
+-fi
+-dnl AC_SUBST(AUDIOFILELIBS)
+-test x$use_audiofile = xfalse && AUDIOFILE_LIBS=
+-test x$use_audiofile = xfalse && AUDIOFILE_CFLAGS=
+-AM_CONDITIONAL(AUDIOFILE, test x$use_audiofile = xtrue)
++AS_IF([test "x$with_audiofile" = "xyes"], [
++ PKG_CHECK_MODULES([AUDIOFILE], [audiofile])
++ AC_DEFINE(USE_AUDIOFILE)
++])
++AM_CONDITIONAL(AUDIOFILE, test x$with_audiofile = xyes)
+
+
+ dnl *** Stuff for mad mpeg audio decoder library ***
+@@ -330,7 +313,7 @@
+
+ echo
+ echo "Configuration:"
+-echo " audiofile library: $use_audiofile"
++echo " audiofile library: $with_audiofile"
+ echo " mpeg audio support: $use_mad"
+ echo " xmms volume adjust plugin: $use_xmms"
+ echo