summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 12:09:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:42 +0100
commitce86df7eb9cdd27b8da28b84541ed0894fac4b53 (patch)
tree3924362d6b5210d43d0502e02ac8f34b776b09c9 /media-sound/drumstick
parentkde5.eclass: Switch to cmake.eclass (diff)
downloadgentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.gz
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.bz2
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.zip
*/*: Switch kde proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/drumstick')
-rw-r--r--media-sound/drumstick/drumstick-1.1.2.ebuild14
-rw-r--r--media-sound/drumstick/drumstick-1.1.3.ebuild14
2 files changed, 14 insertions, 14 deletions
diff --git a/media-sound/drumstick/drumstick-1.1.2.ebuild b/media-sound/drumstick/drumstick-1.1.2.ebuild
index c76b61480434..cf6137ec098e 100644
--- a/media-sound/drumstick/drumstick-1.1.2.ebuild
+++ b/media-sound/drumstick/drumstick-1.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
HOMEPAGE="http://drumstick.sourceforge.net/"
@@ -41,7 +41,7 @@ DOCS=( AUTHORS ChangeLog NEWS README TODO )
RESTRICT="test"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use fluidsynth ; then
sed -i -e "/pkg_check_modules(FLUIDSYNTH/d" \
@@ -58,19 +58,19 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=OFF
- $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake_use_find_package doc Doxygen)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doxygen
+ cmake_src_compile
+ use doc && cmake_src_compile doxygen
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use doc ; then
dodoc -r "${BUILD_DIR}"/doc/html
diff --git a/media-sound/drumstick/drumstick-1.1.3.ebuild b/media-sound/drumstick/drumstick-1.1.3.ebuild
index f6de2bd3fcc8..fbb7e14743ec 100644
--- a/media-sound/drumstick/drumstick-1.1.3.ebuild
+++ b/media-sound/drumstick/drumstick-1.1.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
HOMEPAGE="http://drumstick.sourceforge.net/"
@@ -41,7 +41,7 @@ DOCS=( AUTHORS ChangeLog NEWS README TODO )
RESTRICT="test"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use fluidsynth ; then
sed -i -e "/pkg_check_modules(FLUIDSYNTH/d" \
@@ -58,19 +58,19 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=OFF
- $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake_use_find_package doc Doxygen)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doxygen
+ cmake_src_compile
+ use doc && cmake_src_compile doxygen
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use doc ; then
dodoc -r "${BUILD_DIR}"/doc/html