summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/drumstick
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/drumstick')
-rw-r--r--media-sound/drumstick/Manifest2
-rw-r--r--media-sound/drumstick/drumstick-0.5.0.ebuild69
-rw-r--r--media-sound/drumstick/drumstick-1.0.0.ebuild75
-rw-r--r--media-sound/drumstick/files/0.5.0-doc_automagicness.patch20
-rw-r--r--media-sound/drumstick/files/0.5.0-underlinking.patch17
-rw-r--r--media-sound/drumstick/metadata.xml9
6 files changed, 192 insertions, 0 deletions
diff --git a/media-sound/drumstick/Manifest b/media-sound/drumstick/Manifest
new file mode 100644
index 000000000000..0e64de03a449
--- /dev/null
+++ b/media-sound/drumstick/Manifest
@@ -0,0 +1,2 @@
+DIST drumstick-0.5.0.tar.bz2 200914 SHA256 5a12bcf2a26dac7f2a5c9507c662c4c85556881c64bb55365dceb437cf3652cd SHA512 12078dbeae7166da210ccbbaee9d55b4c9e233fd317de72c20482466cd29987c976290efecd29cc28a5be6ed7e3b9fe95ddf1081d75222d9cf9d6aef13080a21 WHIRLPOOL 6d7b35259280aacf0ec414868068f136c39bb8e488848d110739481cbf6bb874cb46c95b98bc8f541185816ff81819494716e2706d9e6a59519bdc2e9520a425
+DIST drumstick-1.0.0.tar.bz2 231036 SHA256 c10520e34524c904a24b7f93cddcdcb95eec3cd2f358d96be8dfc809df062b99 SHA512 631ea32ab1a611266c650d6e9c4be564556f9c965c85a600097bbe909d594f601c917ff9fb46af444a0907472dd522e61bca6d4111ad6b1beec06ae267c5e33a WHIRLPOOL 9fbdc310326b8ae6ab468182d9c6dad07b2961fbfa4a53ad611f0a4a2f51ccf03ddd28f19a9731181e3b94387245706ea1d40950c6c99e311a9dcdd4e845cebb
diff --git a/media-sound/drumstick/drumstick-0.5.0.ebuild b/media-sound/drumstick/drumstick-0.5.0.ebuild
new file mode 100644
index 000000000000..3df4f17c5ba5
--- /dev/null
+++ b/media-sound/drumstick/drumstick-0.5.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base cmake-utils fdo-mime gnome2-utils
+
+DESCRIPTION="Qt4/C++ wrapper for ALSA sequencer"
+HOMEPAGE="http://drumstick.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dbus doc"
+
+RDEPEND="media-libs/alsa-lib
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ x11-misc/shared-mime-info
+ dbus? ( dev-qt/qtdbus:4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-doc_automagicness.patch
+ "${FILESDIR}"/${PV}-underlinking.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e '/CMAKE_EXE_LINKER_FLAGS/d' \
+ CMakeLists.txt || die
+ base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use dbus)
+ $(cmake-utils_use_with doc)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/drumstick/drumstick-1.0.0.ebuild b/media-sound/drumstick/drumstick-1.0.0.ebuild
new file mode 100644
index 000000000000..0895566374cb
--- /dev/null
+++ b/media-sound/drumstick/drumstick-1.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils fdo-mime gnome2-utils
+
+DESCRIPTION="Qt4/C++ wrapper for ALSA sequencer"
+HOMEPAGE="http://drumstick.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ x11-misc/shared-mime-info
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package doc Doxygen)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile doxygen
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc ; then
+ dodoc -r "${BUILD_DIR}"/doc/html
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/drumstick/files/0.5.0-doc_automagicness.patch b/media-sound/drumstick/files/0.5.0-doc_automagicness.patch
new file mode 100644
index 000000000000..c2474ae4f1e1
--- /dev/null
+++ b/media-sound/drumstick/files/0.5.0-doc_automagicness.patch
@@ -0,0 +1,20 @@
+diff -urN drumstick-0.5.0.old/CMakeLists.txt drumstick-0.5.0/CMakeLists.txt
+--- drumstick-0.5.0.old/CMakeLists.txt 2010-09-09 12:38:56.000000000 +0200
++++ drumstick-0.5.0/CMakeLists.txt 2011-05-13 11:03:30.156962982 +0200
+@@ -143,6 +143,8 @@
+ ADD_SUBDIRECTORY(library)
+ ADD_SUBDIRECTORY(utils)
+ ADD_SUBDIRECTORY(icons)
++OPTION(WITH_DOC "Build documentation" ON)
++IF( WITH_DOC )
+ IF(${CMAKE_SYSTEM} MATCHES "Linux")
+ FIND_PACKAGE(Doxygen)
+ IF(DOXYGEN_FOUND)
+@@ -157,6 +159,7 @@
+ ENDIF(DOXYGEN_FOUND)
+ ADD_SUBDIRECTORY(doc)
+ ENDIF(${CMAKE_SYSTEM} MATCHES "Linux")
++ENDIF( WITH_DOC )
+
+ CONFIGURE_FILE(drumstick-alsa.pc.in drumstick-alsa.pc IMMEDIATE @ONLY)
+ CONFIGURE_FILE(drumstick-file.pc.in drumstick-file.pc IMMEDIATE @ONLY)
diff --git a/media-sound/drumstick/files/0.5.0-underlinking.patch b/media-sound/drumstick/files/0.5.0-underlinking.patch
new file mode 100644
index 000000000000..1bb5ae7da3bf
--- /dev/null
+++ b/media-sound/drumstick/files/0.5.0-underlinking.patch
@@ -0,0 +1,17 @@
+--- utils/vpiano/CMakeLists.txt
++++ utils/vpiano/CMakeLists.txt
+@@ -1,3 +1,5 @@
++find_package(X11 REQUIRED)
++
+ SET(vpiano_forms_SRCS
+ vpianoabout.ui
+ connections.ui
+@@ -52,7 +54,7 @@
+ TARGET_LINK_LIBRARIES(drumstick-vpiano
+ ${QT_LIBRARIES}
+ ${ALSA_LIBS}
+- ${QT_X11_X11_LIBRARY}
++ ${X11_X11_LIB}
+ drumstick-common
+ drumstick-alsa
+ )
diff --git a/media-sound/drumstick/metadata.xml b/media-sound/drumstick/metadata.xml
new file mode 100644
index 000000000000..1438ab505c5b
--- /dev/null
+++ b/media-sound/drumstick/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">drumstick</remote-id>
+ </upstream>
+</pkgmetadata>