summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-09-23 19:41:35 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-09-23 21:00:48 +0200
commit5c0a1801d1d70319c50aa4ce288c12ffa688e536 (patch)
tree8090c635e6fc5f1b991c445c79a500ecc63e990c /media-plugins/vdr-epgsearch
parentdev-vcs/git-cola: remove unused patch (diff)
downloadgentoo-5c0a1801d1d70319c50aa4ce288c12ffa688e536.tar.gz
gentoo-5c0a1801d1d70319c50aa4ce288c12ffa688e536.tar.bz2
gentoo-5c0a1801d1d70319c50aa4ce288c12ffa688e536.zip
media-plugins/vdr-epgsearch: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/22374 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-epgsearch')
-rw-r--r--media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.x.makefile.patch25
-rw-r--r--media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.4.0_p20200402_clang.patch33
2 files changed, 0 insertions, 58 deletions
diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.x.makefile.patch b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.x.makefile.patch
deleted file mode 100644
index 25e27e958a4a..000000000000
--- a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.x.makefile.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naur vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile
---- vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile 2015-02-21 21:01:08.926052710 +0100
-+++ vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile 2015-02-21 21:03:42.768052710 +0100
-@@ -255,9 +255,9 @@
- docs:
- ./docsrc2man.sh
- ./docsrc2html.sh
-- ln -sf ./doc/en/epgsearch.4.txt MANUAL
-- ln -sf ./doc/en/epgsearch.1.txt README
-- ln -sf ./doc/de/epgsearch.1.txt README.DE
-+# ln -sf ./doc/en/epgsearch.4.txt MANUAL
-+# ln -sf ./doc/en/epgsearch.1.txt README
-+# ln -sf ./doc/de/epgsearch.1.txt README.DE
-
- install-$(PLUGIN): libvdr-$(PLUGIN).so
- install -D libvdr-$(PLUGIN).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
-@@ -272,7 +272,7 @@
- install -D libvdr-$(PLUGIN4).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN4).so.$(APIVERSION)
-
- install-conf:
-- mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)/conf.d
-+ mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)
- cp -n conf/* $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)
-
- install-doc:
diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.4.0_p20200402_clang.patch b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.4.0_p20200402_clang.patch
deleted file mode 100644
index 98e642593a4e..000000000000
--- a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.4.0_p20200402_clang.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-when compiling with CC="clang" CXX="clang++" it aborts with
-
-
-createcats.c:71:42: error: ordered comparison between pointer and zero ('char *' and 'int')
- if (fgets(buffer, sizeof(buffer), f) > 0) {
- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~
-
-This patch fixes it.
-
-Signed-off-by: Martin Dummer <martin.dummer@gmx.net> ( 2021-02-16 )
-
---- a/epgsearchext.c 2021-02-14 02:29:17.347224714 +0100
-+++ b/epgsearchext.c 2021-02-14 09:12:46.606509411 +0100
-@@ -1424,7 +1424,7 @@
- int line = 0;
- char buffer[MAXPARSEBUFFER];
- result = true;
-- while (fgets(buffer, sizeof(buffer), f) > 0) {
-+ while (fgets(buffer, sizeof(buffer), f) != NULL) {
- line++;
- char *p = strchr(buffer, '#');
- if (p == buffer) *p = 0;
---- a/createcats.c 2021-02-14 09:18:05.146499999 +0100
-+++ b/createcats.c 2021-02-14 09:18:25.974499384 +0100
-@@ -68,7 +68,7 @@
-
- char *cReadLine::Read(FILE *f)
- {
-- if (fgets(buffer, sizeof(buffer), f) > 0) {
-+ if (fgets(buffer, sizeof(buffer), f) != NULL) {
- int l = strlen(buffer) - 1;
- if (l >= 0 && buffer[l] == '\n')
- buffer[l] = 0;