summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-09-17 09:41:40 -0400
committerCraig Andrews <candrews@gentoo.org>2020-09-17 09:41:40 -0400
commit02c4451e2652c32f6d45fc0556307c7553b78d1f (patch)
treea1bcabed8fb561dd008852fb6cbdf18a0b4ce20a /media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild
parentmedia-plugins/kodi-pvr-mythtv: 7.1.1 version bump (diff)
downloadgentoo-02c4451e2652c32f6d45fc0556307c7553b78d1f.tar.gz
gentoo-02c4451e2652c32f6d45fc0556307c7553b78d1f.tar.bz2
gentoo-02c4451e2652c32f6d45fc0556307c7553b78d1f.zip
media-plugins/kodi-vfs-sftp: 2.0.0 version bump
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild')
-rw-r--r--media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild
new file mode 100644
index 000000000000..4f57d2b4aa6c
--- /dev/null
+++ b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="SFTP VFS addon for Kodi"
+HOMEPAGE="https://github.com/xbmc/vfs.sftp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/vfs.sftp.git"
+ EGIT_BRANCH="Matrix"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/vfs.sftp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vfs.sftp-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ net-libs/libssh[sftp]
+ =media-tv/kodi-19*
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}