summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-07-29 11:54:14 -0400
committerCraig Andrews <candrews@gentoo.org>2020-07-29 14:10:45 -0400
commita16363f8f7e8e7d406c42caa03b5542418409d74 (patch)
tree20ea024247a3e9eb77422755b19795a745d397aa /media-plugins/kodi-inputstream-rtmp
parentmedia-plugins/kodi-inputstream-adaptive: 2.6.0 version bump (diff)
downloadgentoo-a16363f8f7e8e7d406c42caa03b5542418409d74.tar.gz
gentoo-a16363f8f7e8e7d406c42caa03b5542418409d74.tar.bz2
gentoo-a16363f8f7e8e7d406c42caa03b5542418409d74.zip
media-plugins/kodi-inputstream-rtmp: 3.1.1 version bump
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-inputstream-rtmp')
-rw-r--r--media-plugins/kodi-inputstream-rtmp/Manifest1
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.1.1.ebuild42
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild2
3 files changed, 44 insertions, 1 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/Manifest b/media-plugins/kodi-inputstream-rtmp/Manifest
index c47950f3cc7b..cb6746b37afd 100644
--- a/media-plugins/kodi-inputstream-rtmp/Manifest
+++ b/media-plugins/kodi-inputstream-rtmp/Manifest
@@ -1 +1,2 @@
DIST kodi-inputstream-rtmp-2.0.9.tar.gz 66408 BLAKE2B 466419ef7182c53ddbe358ffb9480f756b8ab7f1f8fe790bb7942ac1cbd14731e4ef2faa0c15d31652733fe49881cf7588a6e560e6f132b61da47d7a8e0e0367 SHA512 b38b45f6313bcf2827eabf80875840b8b24cf010e0f44c20241f8a20f438273020ebd34078562581c34c83f3c9109ec953ef1de819c85de2260f0377903fbd23
+DIST kodi-inputstream-rtmp-3.1.1.tar.gz 75658 BLAKE2B 4a776d3e44326cfa8195ad75b49eecba08d4a6de6a43ea51ee31791556ed2a28536e77033d0c9833838be9a27b2a32dc5ac34c4e9ee92e7a9084b021afbd1100 SHA512 9509fe681c3e2699ebe18a3090bd31c32ccc2634ee0c3c5a686b380ce1d104ff7ec1620f6615495d26fb271164592c0cb4f287ef1852468edddfec9440773a53
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.1.1.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.1.1.ebuild
new file mode 100644
index 000000000000..77cc18556943
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_BRANCH="Matrix"
+ EGIT_REPO_URI="https://github.com/xbmc/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/inputstream.rtmp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
index 65b4a76c90df..4bdb525a8caa 100644
--- a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
@@ -17,7 +17,7 @@ case ${PV} in
inherit git-r3
;;
*)
- CODENAME="Leia"
+ CODENAME="Matrix"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/xbmc/inputstream.rtmp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/inputstream.rtmp-${PV}-${CODENAME}"