summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-03 11:22:16 +0100
committerSam James <sam@gentoo.org>2024-10-03 11:23:38 +0100
commit1c5b79a1737d2a3ef083a3745b2eb2fc9e6681be (patch)
treeaf10e68a6103b8ead0ba174844d5562d3b612697 /media-libs
parentnet-libs/webkit-gtk: Stabilize 2.44.4-r600 amd64, #940643 (diff)
downloadgentoo-1c5b79a1737d2a3ef083a3745b2eb2fc9e6681be.tar.gz
gentoo-1c5b79a1737d2a3ef083a3745b2eb2fc9e6681be.tar.bz2
gentoo-1c5b79a1737d2a3ef083a3745b2eb2fc9e6681be.zip
media-libs/mesa: filter LTO unconditionally
Mesa seems to have a tonne of issues with LTO and had some reports on IRC of hitting possibly https://gitlab.freedesktop.org/mesa/mesa/-/issues/11846 w/ GCC 13. Not worth the constant games with this, just filter unconditionally given we keep hearing of these different bugs involving LTO and none of them have been rootcaused/debugged/analysed upstream. Bug: https://gitlab.freedesktop.org/mesa/mesa/-/issues/11846 Bug: https://bugs.gentoo.org/932591 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-24.1.7.ebuild4
-rw-r--r--media-libs/mesa/mesa-24.2.3.ebuild4
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-24.1.7.ebuild b/media-libs/mesa/mesa-24.1.7.ebuild
index 21a8ac3b80e2..af5ee095a972 100644
--- a/media-libs/mesa/mesa-24.1.7.ebuild
+++ b/media-libs/mesa/mesa-24.1.7.ebuild
@@ -8,7 +8,7 @@ LLVM_OPTIONAL=1
CARGO_OPTIONAL=1
PYTHON_COMPAT=( python3_{10..12} )
-inherit flag-o-matic llvm-r1 meson-multilib python-any-r1 linux-info rust-toolchain toolchain-funcs
+inherit flag-o-matic llvm-r1 meson-multilib python-any-r1 linux-info rust-toolchain
MY_P="${P/_/-}"
@@ -303,7 +303,7 @@ multilib_src_configure() {
local emesonargs=()
# bug #932591 and https://gitlab.freedesktop.org/mesa/mesa/-/issues/11140
- tc-is-gcc && [[ $(gcc-major-version) -ge 14 ]] && filter-lto
+ filter-lto
local platforms
use X && platforms+="x11"
diff --git a/media-libs/mesa/mesa-24.2.3.ebuild b/media-libs/mesa/mesa-24.2.3.ebuild
index f6e781d20e57..a58a2652340e 100644
--- a/media-libs/mesa/mesa-24.2.3.ebuild
+++ b/media-libs/mesa/mesa-24.2.3.ebuild
@@ -8,7 +8,7 @@ LLVM_OPTIONAL=1
CARGO_OPTIONAL=1
PYTHON_COMPAT=( python3_{10..13} )
-inherit flag-o-matic llvm-r1 meson-multilib python-any-r1 linux-info rust-toolchain toolchain-funcs
+inherit flag-o-matic llvm-r1 meson-multilib python-any-r1 linux-info rust-toolchain
MY_P="${P/_/-}"
@@ -307,7 +307,7 @@ multilib_src_configure() {
local emesonargs=()
# bug #932591 and https://gitlab.freedesktop.org/mesa/mesa/-/issues/11140
- tc-is-gcc && [[ $(gcc-major-version) -ge 14 ]] && filter-lto
+ filter-lto
local platforms
use X && platforms+="x11"
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index f213fe761cb9..477f8e886fcc 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -8,7 +8,7 @@ LLVM_OPTIONAL=1
CARGO_OPTIONAL=1
PYTHON_COMPAT=( python3_{10..13} )
-inherit flag-o-matic llvm-r1 meson-multilib python-any-r1 linux-info rust-toolchain toolchain-funcs
+inherit flag-o-matic llvm-r1 meson-multilib python-any-r1 linux-info rust-toolchain
MY_P="${P/_/-}"
@@ -306,7 +306,7 @@ multilib_src_configure() {
local emesonargs=()
# bug #932591 and https://gitlab.freedesktop.org/mesa/mesa/-/issues/11140
- tc-is-gcc && [[ $(gcc-major-version) -ge 14 ]] && filter-lto
+ filter-lto
local platforms
use X && platforms+="x11"