summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiccolò Belli <niccolo.belli@linuxsystems.it>2023-02-23 10:13:27 +0100
committerSam James <sam@gentoo.org>2023-09-15 10:15:56 +0100
commit1869e5c50ca0705e8bb2bbe144273ea272215946 (patch)
tree70b2e204a0dde8752d41a52bd6c106b84514393e /media-libs/webrtc-audio-processing
parentprofiles/updates: fix OldPackageUpdate (diff)
downloadgentoo-1869e5c50ca0705e8bb2bbe144273ea272215946.tar.gz
gentoo-1869e5c50ca0705e8bb2bbe144273ea272215946.tar.bz2
gentoo-1869e5c50ca0705e8bb2bbe144273ea272215946.zip
media-libs/webrtc-audio-processing: add big-endian patches, keyword 0.3.1 for ~ppc64
Signed-off-by: Niccolò Belli <niccolo.belli@linuxsystems.it> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/webrtc-audio-processing')
-rw-r--r--media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-Add-generic-byte-order-and-pointer-size-detection.patch35
-rw-r--r--media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-big-endian-support.patch103
-rw-r--r--media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild36
3 files changed, 174 insertions, 0 deletions
diff --git a/media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-Add-generic-byte-order-and-pointer-size-detection.patch b/media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-Add-generic-byte-order-and-pointer-size-detection.patch
new file mode 100644
index 000000000000..0c4508986e4b
--- /dev/null
+++ b/media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-Add-generic-byte-order-and-pointer-size-detection.patch
@@ -0,0 +1,35 @@
+From: Than <than@redhat.com>
+Date: Wed, 8 Jun 2016 19:10:08 -0400
+Subject: Add generic byte order and pointer size detection
+
+https://sources.debian.org/patches/webrtc-audio-processing/0.3-1/Add-generic-byte-order-and-pointer-size-detection.patch/
+https://bugs.freedesktop.org/show_bug.cgi?id=95738
+---
+ webrtc/typedefs.h | 14 +++++++++++++-
+ 1 file changed, 13 insertions(+), 1 deletion(-)
+
+diff --git a/webrtc/typedefs.h b/webrtc/typedefs.h
+index d875490..dc074f1 100644
+--- a/webrtc/typedefs.h
++++ b/webrtc/typedefs.h
+@@ -48,7 +48,19 @@
+ #define WEBRTC_ARCH_32_BITS
+ #define WEBRTC_ARCH_LITTLE_ENDIAN
+ #else
+-#error Please add support for your architecture in typedefs.h
++/* instead of failing, use typical unix defines... */
++#if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++#define WEBRTC_ARCH_LITTLE_ENDIAN
++#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
++#define WEBRTC_ARCH_BIG_ENDIAN
++#else
++#error __BYTE_ORDER__ is not defined
++#endif
++#if defined(__LP64__)
++#define WEBRTC_ARCH_64_BITS
++#else
++#define WEBRTC_ARCH_32_BITS
++#endif
+ #endif
+
+ #if !(defined(WEBRTC_ARCH_LITTLE_ENDIAN) ^ defined(WEBRTC_ARCH_BIG_ENDIAN))
diff --git a/media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-big-endian-support.patch b/media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-big-endian-support.patch
new file mode 100644
index 000000000000..34f27dd70484
--- /dev/null
+++ b/media-libs/webrtc-audio-processing/files/webrtc-audio-processing-0.3-big-endian-support.patch
@@ -0,0 +1,103 @@
+From: Than <than@redhat.com>
+Date: Mon, 6 Jun 2016 12:08:58 -0400
+Subject: big endian support
+
+https://sources.debian.org/patches/webrtc-audio-processing/0.3-1/big-endian-support.patch/
+https://bugs.freedesktop.org/show_bug.cgi?id=95738
+---
+ webrtc/common_audio/wav_file.cc | 20 +++++++++++++++-----
+ webrtc/common_audio/wav_header.cc | 34 +++++++++++++++++++++++++++++++++-
+ 2 files changed, 48 insertions(+), 6 deletions(-)
+
+diff --git a/webrtc/common_audio/wav_file.cc b/webrtc/common_audio/wav_file.cc
+index b14b620..05fa052 100644
+--- a/webrtc/common_audio/wav_file.cc
++++ b/webrtc/common_audio/wav_file.cc
+@@ -64,9 +64,6 @@ WavReader::~WavReader() {
+ }
+
+ size_t WavReader::ReadSamples(size_t num_samples, int16_t* samples) {
+-#ifndef WEBRTC_ARCH_LITTLE_ENDIAN
+-#error "Need to convert samples to big-endian when reading from WAV file"
+-#endif
+ // There could be metadata after the audio; ensure we don't read it.
+ num_samples = std::min(rtc::checked_cast<uint32_t>(num_samples),
+ num_samples_remaining_);
+@@ -76,6 +73,12 @@ size_t WavReader::ReadSamples(size_t num_samples, int16_t* samples) {
+ RTC_CHECK(read == num_samples || feof(file_handle_));
+ RTC_CHECK_LE(read, num_samples_remaining_);
+ num_samples_remaining_ -= rtc::checked_cast<uint32_t>(read);
++#ifndef WEBRTC_ARCH_LITTLE_ENDIAN
++ //convert to big-endian
++ for(size_t idx = 0; idx < num_samples; idx++) {
++ samples[idx] = (samples[idx]<<8) | (samples[idx]>>8);
++ }
++#endif
+ return read;
+ }
+
+@@ -120,10 +123,17 @@ WavWriter::~WavWriter() {
+
+ void WavWriter::WriteSamples(const int16_t* samples, size_t num_samples) {
+ #ifndef WEBRTC_ARCH_LITTLE_ENDIAN
+-#error "Need to convert samples to little-endian when writing to WAV file"
+-#endif
++ int16_t * le_samples = new int16_t[num_samples];
++ for(size_t idx = 0; idx < num_samples; idx++) {
++ le_samples[idx] = (samples[idx]<<8) | (samples[idx]>>8);
++ }
++ const size_t written =
++ fwrite(le_samples, sizeof(*le_samples), num_samples, file_handle_);
++ delete []le_samples;
++#else
+ const size_t written =
+ fwrite(samples, sizeof(*samples), num_samples, file_handle_);
++#endif
+ RTC_CHECK_EQ(num_samples, written);
+ num_samples_ += static_cast<uint32_t>(written);
+ RTC_CHECK(written <= std::numeric_limits<uint32_t>::max() ||
+diff --git a/webrtc/common_audio/wav_header.cc b/webrtc/common_audio/wav_header.cc
+index 61cfffe..53882ff 100644
+--- a/webrtc/common_audio/wav_header.cc
++++ b/webrtc/common_audio/wav_header.cc
+@@ -129,7 +129,39 @@ static inline std::string ReadFourCC(uint32_t x) {
+ return std::string(reinterpret_cast<char*>(&x), 4);
+ }
+ #else
+-#error "Write be-to-le conversion functions"
++static inline void WriteLE16(uint16_t* f, uint16_t x) {
++ *f = ((x << 8) & 0xff00) | ( ( x >> 8) & 0x00ff);
++}
++
++static inline void WriteLE32(uint32_t* f, uint32_t x) {
++ *f = ( (x & 0x000000ff) << 24 )
++ | ((x & 0x0000ff00) << 8)
++ | ((x & 0x00ff0000) >> 8)
++ | ((x & 0xff000000) >> 24 );
++}
++
++static inline void WriteFourCC(uint32_t* f, char a, char b, char c, char d) {
++ *f = (static_cast<uint32_t>(a) << 24 )
++ | (static_cast<uint32_t>(b) << 16)
++ | (static_cast<uint32_t>(c) << 8)
++ | (static_cast<uint32_t>(d) );
++}
++
++static inline uint16_t ReadLE16(uint16_t x) {
++ return (( x & 0x00ff) << 8 )| ((x & 0xff00)>>8);
++}
++
++static inline uint32_t ReadLE32(uint32_t x) {
++ return ( (x & 0x000000ff) << 24 )
++ | ( (x & 0x0000ff00) << 8 )
++ | ( (x & 0x00ff0000) >> 8)
++ | ( (x & 0xff000000) >> 24 );
++}
++
++static inline std::string ReadFourCC(uint32_t x) {
++ x = ReadLE32(x);
++ return std::string(reinterpret_cast<char*>(&x), 4);
++}
+ #endif
+
+ static inline uint32_t RiffChunkSize(uint32_t bytes_in_payload) {
diff --git a/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild b/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..946115a3b322
--- /dev/null
+++ b/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="AudioProcessing library from the webrtc.org code base"
+HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+DOCS=( AUTHORS NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3-proper_detection_cxxabi_execinfo.patch
+ "${FILESDIR}"/${PN}-0.3-Add-generic-byte-order-and-pointer-size-detection.patch
+ "${FILESDIR}"/${PN}-0.3-big-endian-support.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}