summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-27 18:21:46 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-03 18:14:11 -0700
commit00e21d92f986a86d3868fe7ff066c68b15176a72 (patch)
treef8612f8fac723058bfd6864ec0d273f19a09b86c /media-libs/waffle
parentmedia-libs/rubberband: Switch to meson-multilib (diff)
downloadgentoo-00e21d92f986a86d3868fe7ff066c68b15176a72.tar.gz
gentoo-00e21d92f986a86d3868fe7ff066c68b15176a72.tar.bz2
gentoo-00e21d92f986a86d3868fe7ff066c68b15176a72.zip
media-libs/waffle: Switch to meson-multilib
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/waffle')
-rw-r--r--media-libs/waffle/waffle-1.7.0.ebuild8
-rw-r--r--media-libs/waffle/waffle-9999.ebuild8
2 files changed, 4 insertions, 12 deletions
diff --git a/media-libs/waffle/waffle-1.7.0.ebuild b/media-libs/waffle/waffle-1.7.0.ebuild
index 1a2174a6add7..b58cfad30b98 100644
--- a/media-libs/waffle/waffle-1.7.0.ebuild
+++ b/media-libs/waffle/waffle-1.7.0.ebuild
@@ -11,7 +11,7 @@ else
KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
S="${WORKDIR}"/${PN}-v${PV}
fi
-inherit meson multilib-minimal ${GIT_ECLASS}
+inherit meson-multilib ${GIT_ECLASS}
DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
@@ -49,16 +49,12 @@ multilib_src_configure() {
$(meson_feature X x11_egl)
$(meson_feature gbm)
$(meson_feature egl surfaceless_egl)
- -Dbuild-manpages=$(multilib_is_native_abi && echo true || echo false)
+ $(meson_native_true build-manpages)
-Dbuild-tests=false
)
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
-}
-
multilib_src_install() {
meson_src_install
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index 1a2174a6add7..b58cfad30b98 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -11,7 +11,7 @@ else
KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
S="${WORKDIR}"/${PN}-v${PV}
fi
-inherit meson multilib-minimal ${GIT_ECLASS}
+inherit meson-multilib ${GIT_ECLASS}
DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
@@ -49,16 +49,12 @@ multilib_src_configure() {
$(meson_feature X x11_egl)
$(meson_feature gbm)
$(meson_feature egl surfaceless_egl)
- -Dbuild-manpages=$(multilib_is_native_abi && echo true || echo false)
+ $(meson_native_true build-manpages)
-Dbuild-tests=false
)
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
-}
-
multilib_src_install() {
meson_src_install