summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-10 22:57:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-10 23:17:19 -0400
commitbcfdddb51006ad429082201cb2436ab684a544dd (patch)
tree9f20a45ada05ecb1c6a7b9f975fb53537cfd8577 /media-libs/volpack
parentgames-board/xskat: fix w/ upcoming clang16 + -std=gnu89 (diff)
downloadgentoo-bcfdddb51006ad429082201cb2436ab684a544dd.tar.gz
gentoo-bcfdddb51006ad429082201cb2436ab684a544dd.tar.bz2
gentoo-bcfdddb51006ad429082201cb2436ab684a544dd.zip
media-libs/volpack: further fix w/ upcoming clang16 + -std=gnu89
Forgot the patch for the missing int last time and only fixed examples. Bug: https://bugs.gentoo.org/870706 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs/volpack')
-rw-r--r--media-libs/volpack/files/volpack-1.0_p7-clang16.patch8
-rw-r--r--media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch4
-rw-r--r--media-libs/volpack/volpack-1.0_p7-r2.ebuild9
3 files changed, 19 insertions, 2 deletions
diff --git a/media-libs/volpack/files/volpack-1.0_p7-clang16.patch b/media-libs/volpack/files/volpack-1.0_p7-clang16.patch
new file mode 100644
index 000000000000..95bb9efbbb8c
--- /dev/null
+++ b/media-libs/volpack/files/volpack-1.0_p7-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/870706
+--- a/src/makeopts.c
++++ b/src/makeopts.c
+@@ -45,3 +45,3 @@
+
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
diff --git a/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch b/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch
index 1476f23084f5..9cb0d0b9b508 100644
--- a/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch
+++ b/media-libs/volpack/files/volpack-1.0_p7-skip-examples.patch
@@ -1,5 +1,5 @@
-Building these is broken with clang16 and they are primarily
-intended to be looked rather rather than built.
+These are intended to be looked at rather than built, this avoids
+installing object files and prevents a build failure with clang16.
https://bugs.gentoo.org/870706
--- a/Makefile.am
diff --git a/media-libs/volpack/volpack-1.0_p7-r2.ebuild b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
index f7076c8c6c31..e3a3ed9dca75 100644
--- a/media-libs/volpack/volpack-1.0_p7-r2.ebuild
+++ b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
MY_P="${PN}-${PV/_p/c}"
DESCRIPTION="Volume rendering library"
@@ -19,8 +21,15 @@ BDEPEND="sys-devel/m4"
PATCHES=(
"${FILESDIR}"/${P}-skip-examples.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
+src_configure() {
+ append-cflags -std=gnu89 # old codebase, will break with c2x
+
+ default
+}
+
src_compile() {
emake -j1
}