summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sdl-image
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sdl-image')
-rw-r--r--media-libs/sdl-image/Manifest1
-rw-r--r--media-libs/sdl-image/metadata.xml8
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild63
3 files changed, 72 insertions, 0 deletions
diff --git a/media-libs/sdl-image/Manifest b/media-libs/sdl-image/Manifest
new file mode 100644
index 000000000000..e47318f0b160
--- /dev/null
+++ b/media-libs/sdl-image/Manifest
@@ -0,0 +1 @@
+DIST SDL_image-1.2.12.tar.gz 2231074 SHA256 0b90722984561004de84847744d566809dbb9daf732a9e503b91a1b5a84e5699 SHA512 0e71b280abc2a7f15755e4480a3c1b52d41f9f8b0c9216a6f5bd9fc0e939456fb5d6c10419e1d1904785783f9a1891ead278c03e88b0466fecc6871c3ca40136 WHIRLPOOL cde2ea45f8a55cec720d05bba450c98ad177fad826938119482f4988c5af6eaaeb53079b749f886329bd59411790f1cafe04d01fff90b44095fc626358578c51
diff --git a/media-libs/sdl-image/metadata.xml b/media-libs/sdl-image/metadata.xml
new file mode 100644
index 000000000000..9758b7a8f6da
--- /dev/null
+++ b/media-libs/sdl-image/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<use>
+ <flag name='webp'>support loading WEBP images</flag>
+</use>
+</pkgmetadata>
diff --git a/media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild b/media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild
new file mode 100644
index 000000000000..dc3bbfbc141a
--- /dev/null
+++ b/media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="image file loading library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_image/"
+SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="
+ abi_x86_32? (
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ !<=app-emulation/emul-linux-x86-sdl-20140406
+ )
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.7-r1:0[${MULTILIB_USEDEP}] )
+ webp? ( >=media-libs/libwebp-0.3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-jpg-shared \
+ --disable-png-shared \
+ --disable-tif-shared \
+ --disable-webp-shared \
+ $(use_enable static-libs static) \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ $(use_enable tiff tif) \
+ $(use_enable png) \
+ $(use_enable webp) \
+ --enable-bmp \
+ --enable-lbm \
+ --enable-pcx \
+ --enable-pnm \
+ --enable-tga \
+ --enable-xcf \
+ --enable-xpm \
+ --enable-xv
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ dobin .libs/showimage
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ use static-libs || prune_libtool_files --all
+}