summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2017-03-17 20:59:48 -0300
committerGuilherme Amadio <amadio@gentoo.org>2017-03-17 21:03:15 -0300
commit754c00c14ed0b98450b515b2d74d57ad2f15a74d (patch)
tree1329435f3e91a95268f5efee6ae85b1e28a6dafc /media-libs/qhull
parentpackage.mask: mask dev-perl/GStreamer dev-perl/GStreamer-Interfaces for removal (diff)
downloadgentoo-754c00c14ed0b98450b515b2d74d57ad2f15a74d.tar.gz
gentoo-754c00c14ed0b98450b515b2d74d57ad2f15a74d.tar.bz2
gentoo-754c00c14ed0b98450b515b2d74d57ad2f15a74d.zip
media-libs/qhull: Version bump to 2015.2
Package-Manager: Portage-2.3.5-prefix, Repoman-2.3.2
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/Manifest1
-rw-r--r--media-libs/qhull/qhull-2015.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/qhull/Manifest b/media-libs/qhull/Manifest
index 3fb67aff5e81..bfb1c451af84 100644
--- a/media-libs/qhull/Manifest
+++ b/media-libs/qhull/Manifest
@@ -1 +1,2 @@
DIST qhull-2012.1-src.tgz 716665 SHA256 a35ecaa610550b7f05c3ce373d89c30cf74b059a69880f03080c556daebcff88 SHA512 e35ea2cb73ef32b23b64a6594a8b5ea22ed8e2ea7535cfd72dca44331602368dfcb681600a0d2b090e80e67e6be7b32272244b9083d4805f2fbcf5897eb73240 WHIRLPOOL 37704b3f94b6d20c02886598cc2e862f47feb910e0d3259d686b1356242206b77640871509818c56530161720954214d41c295dfe740faa4ed575379b05259f6
+DIST qhull-2015.2.tar.gz 1010153 SHA256 78b010925c3b577adc3d58278787d7df08f7c8fb02c3490e375eab91bb58a436 SHA512 a544f88b5fbabc592fdc4c5533ba58a8f856e018b85128f43d0532a1143123ceb0d5ca9ae1d27722efa5d08092c017bf7715c157d1019f447e6746f23f02dcd4 WHIRLPOOL 77f7f113dc252012e2591996db16da87a585dc83256ddddc36df69df14aaf1329e946104e836670051ad469d0c4bdf2e1572318a1b33ff1cb9ab191d125c494e
diff --git a/media-libs/qhull/qhull-2015.2.ebuild b/media-libs/qhull/qhull-2015.2.ebuild
new file mode 100644
index 000000000000..61a096e50a0f
--- /dev/null
+++ b/media-libs/qhull/qhull-2015.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Geometry library"
+HOMEPAGE="http://www.qhull.org"
+SRC_URI="${HOMEPAGE}/download/${PN}-2015-src-7.2.0.tgz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc static-libs"
+
+DOCS=( Announce.txt File_id.diz README.txt REGISTER.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2012.1-64bit.patch
+ )
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ mycmakeargs+=(
+ -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)
+ -DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${P}/html
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ # compatibility with previous installs
+ dosym libqhull /usr/include/qhull
+ if ! use doc; then
+ rm -rf "${ED}"/usr/share/doc/${P}/html || die
+ fi
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/lib*.a || die
+ fi
+}