summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-06-08 23:36:08 +0200
committerSam James <sam@gentoo.org>2024-06-29 17:49:14 +0100
commit06f56b7e0d3d0427aa7a161e989e0002e714a649 (patch)
tree47b5abcd2fa9570e598d01b037b00db18e3b7a4b /media-libs/osl
parentmedia-libs/osl: drop 1.12.7.0, 1.12.11.0, 1.12.13.0 (diff)
downloadgentoo-06f56b7e0d3d0427aa7a161e989e0002e714a649.tar.gz
gentoo-06f56b7e0d3d0427aa7a161e989e0002e714a649.tar.bz2
gentoo-06f56b7e0d3d0427aa7a161e989e0002e714a649.zip
media-libs/osl: move VEC_REPORT to USE=debug
BATCHED and SIMD support is iffy. This was intended to get better bug reports. Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36062 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/osl')
-rw-r--r--media-libs/osl/osl-1.12.14.0-r1.ebuild9
-rw-r--r--media-libs/osl/osl-1.12.14.0.ebuild9
-rw-r--r--media-libs/osl/osl-1.13.10.0.ebuild9
-rw-r--r--media-libs/osl/osl-1.13.7.0.ebuild9
-rw-r--r--media-libs/osl/osl-9999.ebuild9
5 files changed, 35 insertions, 10 deletions
diff --git a/media-libs/osl/osl-1.12.14.0-r1.ebuild b/media-libs/osl/osl-1.12.14.0-r1.ebuild
index 628b4123b45d..e450385f5016 100644
--- a/media-libs/osl/osl-1.12.14.0-r1.ebuild
+++ b/media-libs/osl/osl-1.12.14.0-r1.ebuild
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="doc gui libcxx nofma partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma partio qt6 test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -177,11 +177,16 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DUSE_OPTIX="no"
- -DVEC_REPORT="yes"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
+ if use debug; then
+ mycmakeargs+=(
+ -DVEC_REPORT="yes"
+ )
+ fi
+
if use gui; then
mycmakeargs+=( -DUSE_QT="yes" )
if ! use qt6; then
diff --git a/media-libs/osl/osl-1.12.14.0.ebuild b/media-libs/osl/osl-1.12.14.0.ebuild
index 5af6590d6486..459fa3084277 100644
--- a/media-libs/osl/osl-1.12.14.0.ebuild
+++ b/media-libs/osl/osl-1.12.14.0.ebuild
@@ -26,7 +26,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( ${X86_CPU_FEATURES[@]/#/cpu_flags_x86_} )
-IUSE="doc gui partio qt6 test ${CPU_FEATURES[@]%:*} python"
+IUSE="debug doc gui partio qt6 test ${CPU_FEATURES[@]%:*} python"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -124,9 +124,14 @@ src_configure() {
-DPYTHON_VERSION="${EPYTHON/python}"
-DUSE_SIMD="$(IFS=","; echo "${mysimd[*]}")"
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
- -DVEC_REPORT=yes
)
+ if use debug; then
+ mycmakeargs+=(
+ -DVEC_REPORT="yes"
+ )
+ fi
+
if use gui; then
mycmakeargs+=( -DUSE_QT=yes )
if ! use qt6; then
diff --git a/media-libs/osl/osl-1.13.10.0.ebuild b/media-libs/osl/osl-1.13.10.0.ebuild
index 9d66a33c3e3d..3df3ad89ba3b 100644
--- a/media-libs/osl/osl-1.13.10.0.ebuild
+++ b/media-libs/osl/osl-1.13.10.0.ebuild
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
@@ -189,11 +189,16 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DOSL_USE_OPTIX="$(usex optix)"
- -DVEC_REPORT="yes"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
+ if use debug; then
+ mycmakeargs+=(
+ -DVEC_REPORT="yes"
+ )
+ fi
+
if use gui; then
mycmakeargs+=( -DUSE_QT="yes" )
if ! use qt6; then
diff --git a/media-libs/osl/osl-1.13.7.0.ebuild b/media-libs/osl/osl-1.13.7.0.ebuild
index 404090f7e9f3..a8e64ed97c5f 100644
--- a/media-libs/osl/osl-1.13.7.0.ebuild
+++ b/media-libs/osl/osl-1.13.7.0.ebuild
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -185,11 +185,16 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DOSL_USE_OPTIX="$(usex optix)"
- -DVEC_REPORT="yes"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
+ if use debug; then
+ mycmakeargs+=(
+ -DVEC_REPORT="yes"
+ )
+ fi
+
if use gui; then
mycmakeargs+=( -DUSE_QT="yes" )
if ! use qt6; then
diff --git a/media-libs/osl/osl-9999.ebuild b/media-libs/osl/osl-9999.ebuild
index 9d66a33c3e3d..3df3ad89ba3b 100644
--- a/media-libs/osl/osl-9999.ebuild
+++ b/media-libs/osl/osl-9999.ebuild
@@ -32,7 +32,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( "${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}" )
-IUSE="doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
+IUSE="debug doc gui libcxx nofma optix partio qt6 test ${CPU_FEATURES[*]%:*} python"
RESTRICT="!test? ( test )"
@@ -189,11 +189,16 @@ src_configure() {
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
-DUSE_LIBCPLUSPLUS="$(usex libcxx)"
-DOSL_USE_OPTIX="$(usex optix)"
- -DVEC_REPORT="yes"
-DOpenImageIO_ROOT="${EPREFIX}/usr"
)
+ if use debug; then
+ mycmakeargs+=(
+ -DVEC_REPORT="yes"
+ )
+ fi
+
if use gui; then
mycmakeargs+=( -DUSE_QT="yes" )
if ! use qt6; then