summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/opengtl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/opengtl')
-rw-r--r--media-libs/opengtl/Manifest2
-rw-r--r--media-libs/opengtl/files/opengtl-0.9.18-memcpy.patch11
-rw-r--r--media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch30
-rw-r--r--media-libs/opengtl/metadata.xml5
-rw-r--r--media-libs/opengtl/opengtl-0.9.18.ebuild60
5 files changed, 108 insertions, 0 deletions
diff --git a/media-libs/opengtl/Manifest b/media-libs/opengtl/Manifest
new file mode 100644
index 000000000000..74e031052b1d
--- /dev/null
+++ b/media-libs/opengtl/Manifest
@@ -0,0 +1,2 @@
+DIST OpenGTL-0.9.18.tar.bz2 536113 SHA256 f094b3d2a1a60519975bb3badc05e704f2b93c7a3d2cb753041f2ff27cfcd9f8 SHA512 101c200641d93eb2a31c75bdc80ccc7d7e7f79ea7cf2d4280205e86d2a6ca6357444055dab8a8e4b882067f1aad8b6746a4821d0209a0e53393ce3965b42fb50 WHIRLPOOL 735ea8f1af4b4ca83a441f50362e7a0840487629ec29576374d8e4b757a7ef616b5cbe746b3cfaa34e0532e653026c5d56f2ebb675e9c05acd47e8c3d3ddde42
+DIST opengtl-0.9.18-llvm-3.3.patch 27930 SHA256 c43418bc039660ae86cb86b8b8175342793cb1361c699faa9b6342bc896e3d6c SHA512 1c1d09e08ed1a00c57c86632c4d27edb9fac436e6e86638f176aead513ba3b1bc5216d2d07fa8fbf570156dc0a20e18e8c29f776a180d638cfb4ca6d1d8ea3b7 WHIRLPOOL 3edbe720a563516f38f3bd1650d5bc7ae258447be2432a41d14432bb6a2c3b7bf5e6ef0ac62b45a34fd77a4a0cf9053b01f0a3432e7f76ed96c526a3c970913c
diff --git a/media-libs/opengtl/files/opengtl-0.9.18-memcpy.patch b/media-libs/opengtl/files/opengtl-0.9.18-memcpy.patch
new file mode 100644
index 000000000000..3e6ecd557f41
--- /dev/null
+++ b/media-libs/opengtl/files/opengtl-0.9.18-memcpy.patch
@@ -0,0 +1,11 @@
+diff -r 99a2017746c0 Extensions/PngDC/PngDC.cpp
+--- a/Extensions/PngDC/PngDC.cpp Wed Jan 30 05:28:12 2013 +1100
++++ b/Extensions/PngDC/PngDC.cpp Tue Apr 16 01:59:10 2013 +1000
+@@ -20,6 +20,7 @@
+ #include "PngDC.h"
+
+ #include <png.h>
++#include <string.h>
+
+ #include <config-endian.h>
+
diff --git a/media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch b/media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch
new file mode 100644
index 000000000000..6e6d1bda0af9
--- /dev/null
+++ b/media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch
@@ -0,0 +1,30 @@
+changeset: 1792:99a2017746c0
+tag: tip
+user: Michael Palimaka <kensington@gentoo.org>
+date: Wed Jan 30 05:28:12 2013 +1100
+summary: Fix underlinking.
+
+diff -r e150672a54ad -r 99a2017746c0 OpenGTL/GTLCore/CMakeLists.txt
+--- a/OpenGTL/GTLCore/CMakeLists.txt Sat Dec 29 12:27:12 2012 +0100
++++ b/OpenGTL/GTLCore/CMakeLists.txt Wed Jan 30 05:28:12 2013 +1100
+@@ -10,6 +10,10 @@
+
+ ## GTLCore library ##
+
++if(PTHREAD_FOUND)
++ set(GTLCore_Thread_LIBS pthread)
++endif(PTHREAD_FOUND)
++
+ set(GTLCore_SRCS
+ AbstractColorConverter.cpp
+ AbstractImage.cpp
+@@ -110,7 +114,7 @@
+ set(EXTRA_GTLCORE_LINK_OPTIONS -Wl,-u,__ZTVN4llvm3JITE )
+ endif()
+
+-target_link_libraries(GTLCore ${LLVM_LDFLAGS} ${LLVM_LIBS} ${EXTRA_GTLCORE_LINK_OPTIONS})
++target_link_libraries(GTLCore ${LLVM_LDFLAGS} ${LLVM_LIBS} ${GTLCore_Thread_LIBS} ${EXTRA_GTLCORE_LINK_OPTIONS})
+
+ # Set the ABI version of the library
+ set_target_properties(GTLCore PROPERTIES VERSION ${OPENGTL_LIB_VERSION} SOVERSION ${OPENGTL_LIB_SOVERSION} )
+
diff --git a/media-libs/opengtl/metadata.xml b/media-libs/opengtl/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/media-libs/opengtl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
diff --git a/media-libs/opengtl/opengtl-0.9.18.ebuild b/media-libs/opengtl/opengtl-0.9.18.ebuild
new file mode 100644
index 000000000000..b10fa83f098b
--- /dev/null
+++ b/media-libs/opengtl/opengtl-0.9.18.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="OpenGTL-${PV}"
+
+inherit cmake-utils
+
+DESCRIPTION="Collection of libraries for graphics transformation algorithms"
+HOMEPAGE="http://opengtl.org/"
+SRC_URI="http://download.opengtl.org/${MY_P}.tar.bz2 http://dev.gentoo.org/~creffett/distfiles/${PN}-0.9.18-llvm-3.3.patch"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="debug test"
+
+RDEPEND="
+ media-libs/libpng:0=
+ (
+ <sys-devel/llvm-3.4
+ >=sys-devel/llvm-3.1
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/lcov )
+"
+
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.18-memcpy.patch"
+ "${FILESDIR}/${PN}-0.9.18-underlinking.patch"
+)
+
+src_prepare() {
+ if has_version ">=sys-devel/llvm-3.3"; then
+ epatch "${DISTDIR}/${PN}-0.9.18-llvm-3.3.patch"
+ fi
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE
+ $(cmake-utils_use debug OPENGTL_ENABLE_DEBUG_OUTPUT)
+ $(cmake-utils_use test OPENGTL_BUILD_TESTS)
+ $(cmake-utils_use test OPENGTL_CODE_COVERAGE)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newdoc OpenShiva/doc/reference/region.pdf OpenShiva.pdf
+}