summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-21 12:05:56 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-06 19:00:32 +0100
commite729b3cd5338d75fa01f64730eda23ca7a09f628 (patch)
treeb66671de0048b8ee73d8c26bb56ab16874ed81bc /media-libs/oneVPL-intel-gpu
parentmedia-libs/oneVPL-cpu: new package, add 2022.2.5 (diff)
downloadgentoo-e729b3cd5338d75fa01f64730eda23ca7a09f628.tar.gz
gentoo-e729b3cd5338d75fa01f64730eda23ca7a09f628.tar.bz2
gentoo-e729b3cd5338d75fa01f64730eda23ca7a09f628.zip
media-libs/oneVPL-intel-gpu: new package, add 22.6.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-libs/oneVPL-intel-gpu')
-rw-r--r--media-libs/oneVPL-intel-gpu/Manifest1
-rw-r--r--media-libs/oneVPL-intel-gpu/metadata.xml14
-rw-r--r--media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-22.6.3.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/oneVPL-intel-gpu/Manifest b/media-libs/oneVPL-intel-gpu/Manifest
new file mode 100644
index 000000000000..c6372d256f43
--- /dev/null
+++ b/media-libs/oneVPL-intel-gpu/Manifest
@@ -0,0 +1 @@
+DIST oneVPL-intel-gpu-22.6.3.tar.gz 6819100 BLAKE2B 9c87c41c072b7e7ef2dd8adcc6843eea564582f4070d452babb6b1eeadc13eb12dbe2e9d6075821954b7f7194f2ed814d3c1f6463c3b078912ee42cd684d1277 SHA512 56b29513142dc434732e646e3ec3e8d60db542f3be315190b06e9b532e4aef98423be9a0b6f35e65489085786446ecbd1c1774d06bea7552aaa7fb71517f4fb9
diff --git a/media-libs/oneVPL-intel-gpu/metadata.xml b/media-libs/oneVPL-intel-gpu/metadata.xml
new file mode 100644
index 000000000000..1d48ba0cbeed
--- /dev/null
+++ b/media-libs/oneVPL-intel-gpu/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">oneapi-src/oneVPL-intel-gpu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-22.6.3.ebuild b/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-22.6.3.ebuild
new file mode 100644
index 000000000000..7e2c69f5b324
--- /dev/null
+++ b/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-22.6.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="oneAPI Video Processing Library Intel GPU implementation"
+HOMEPAGE="https://github.com/oneapi-src/oneVPL-intel-gpu"
+SRC_URI="https://github.com/oneapi-src/oneVPL-intel-gpu/archive/refs/tags/intel-onevpl-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-onevpl-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ media-libs/libva
+ x11-libs/libdrm[video_cards_intel]
+"
+# At runtime we need a dispatcher, oneVPL is preferred but mediasdk also works
+RDEPEND="${DEPEND}
+ >=media-libs/libva-intel-media-driver-${PV}
+ || (
+ media-libs/oneVPL[drm,vaapi]
+ media-libs/intel-mediasdk
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_RUNTIME=ON
+ # To build the kernels we need to package the cm-compiler, use pre-built instead
+ -DBUILD_KERNELS=OFF
+ -DBUILD_TESTS="$(usex test)"
+ # This only seems to do something if we BUILD_KERNELS=ON
+ #-DBUILD_TOOLS="$(usex tools)"
+ # OpenCL only has an effect if we build kernels
+ -DENABLE_OPENCL=OFF
+ )
+ cmake_src_configure
+}