summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-10-30 15:06:17 -0700
committerMatt Turner <mattst88@gentoo.org>2021-10-30 16:04:14 -0700
commit2ce2c4236ce68ff169cebe1de33bd0432135f38a (patch)
treecbed910688210fbb61568218ea9e4b8773cf4bf9 /media-libs/mesa
parentmedia-libs/mesa: USE -Dprefer-iris= meson option (diff)
downloadgentoo-2ce2c4236ce68ff169cebe1de33bd0432135f38a.tar.gz
gentoo-2ce2c4236ce68ff169cebe1de33bd0432135f38a.tar.bz2
gentoo-2ce2c4236ce68ff169cebe1de33bd0432135f38a.zip
media-libs/mesa: Enable turnip vulkan driver with VIDEO_CARDS=freedreno
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 3d6bd95e308c..5829adce48f2 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -255,11 +255,12 @@ llvm_check_deps() {
pkg_pretend() {
if use vulkan; then
- if ! use video_cards_i965 &&
+ if ! use video_cards_freedreno &&
+ ! use video_cards_i965 &&
! use video_cards_iris &&
! use video_cards_radeonsi &&
! use video_cards_v3d; then
- ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, iris, radeonsi, or v3d"
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain freedreno, i965, iris, radeonsi, or v3d"
fi
fi
@@ -489,6 +490,7 @@ multilib_src_configure() {
fi
if use vulkan; then
+ vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_i965 intel
vulkan_enable video_cards_iris intel
vulkan_enable video_cards_radeonsi amd