summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-06-18 09:48:44 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-06-18 09:48:44 +0100
commit0e67e05f678fae0a7954614673171eb788be2e64 (patch)
tree30b0177068119c94bc8a59d38feffad059293cfe /media-libs/libopenmpt
parentgui-apps/waybar: remove older version of waybar (diff)
downloadgentoo-0e67e05f678fae0a7954614673171eb788be2e64.tar.gz
gentoo-0e67e05f678fae0a7954614673171eb788be2e64.tar.bz2
gentoo-0e67e05f678fae0a7954614673171eb788be2e64.zip
media-libs/libopenmpt: Version bump to 0.6.4
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/libopenmpt')
-rw-r--r--media-libs/libopenmpt/Manifest1
-rw-r--r--media-libs/libopenmpt/libopenmpt-0.6.4.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/libopenmpt/Manifest b/media-libs/libopenmpt/Manifest
index a48860c2df1a..0a844d568799 100644
--- a/media-libs/libopenmpt/Manifest
+++ b/media-libs/libopenmpt/Manifest
@@ -1,3 +1,4 @@
DIST libopenmpt-0.5.14+release.autotools.tar.gz 1446898 BLAKE2B ab6ff8db2e19d859fecca882aea3e569b58d96d5055ec0dd42494a7eb38fefa9c8b88f4700d354de71346c71c6d9a96327db1c2b7b48e227928dcba0ce7347d6 SHA512 8897549c18afb57c5bf54f4dd8a1d80983829bca958052d76cda1315ef4a37f4201575817b7cedfe17a44ee79051a52aa35b26a51b554091e92c9d2dcf5924a3
DIST libopenmpt-0.6.2+release.autotools.tar.gz 1514140 BLAKE2B 38e8d24352cce92b38ddf8e1f33af7fb72571b88b8f4cbddff626affe2f00bdb73635872d502417e37c68aa0f2254338088bb493b47c688a22d342b3ba54f725 SHA512 a4bbf804d4be72d11216173371ab81703877071cf15e2daaaf59b0eb892d5948072af00bd1ec8c097c23bb3f77bc2c0be6cf853dcf3c7c24aa6109a9f74d0948
DIST libopenmpt-0.6.3+release.autotools.tar.gz 1514410 BLAKE2B e61473b3dcb1c88450b72fdd29b7e22f794134ffdf23222a79bf715c6e1c1810e19a5fb48cd6e1536d1f892349cf90cfa34b90e0a67e1c208e993f2db51af082 SHA512 b9f9cce9ef7d87ad8f18d17603b613fd153d5effdf04de566daabe26afa08b84eb0aa089b94fcbf7cb724befd0a3d93ffdaf5b578f2a3afa31f7aa517f39c62f
+DIST libopenmpt-0.6.4+release.autotools.tar.gz 1547663 BLAKE2B f1c7254146437ce3ca646049c05fe4ae0575012724584a7b2cfce7dfdacf7987eb5403b0634d1961e1b7b176adfbbcbb23a9966d874e489ebcf01524a020750d SHA512 7306ddbe030b8e82ad24fc85083d13d7ca680870f4dbe7215399719cd63ee9ed9e5c4c6229e9f17fb5a2005e86b21ceed0dab158d3f0b73c606579654434421f
diff --git a/media-libs/libopenmpt/libopenmpt-0.6.4.ebuild b/media-libs/libopenmpt/libopenmpt-0.6.4.ebuild
new file mode 100644
index 000000000000..31433906b65f
--- /dev/null
+++ b/media-libs/libopenmpt/libopenmpt-0.6.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+MY_P="libopenmpt-${PV}+release.autotools"
+DESCRIPTION="Library to decode tracked music files (modules)"
+HOMEPAGE="https://lib.openmpt.org/libopenmpt/"
+SRC_URI="https://lib.openmpt.org/files/libopenmpt/src/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+IUSE="examples mp3 ogg static-libs test vorbis zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ mp3? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+ ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )
+ vorbis? ( media-libs/libvorbis[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # A lot of these optional dependencies relate to openmpt123, which
+ # we package separately, so we disable them here.
+ econf \
+ $(use_enable static-libs static) \
+ --disable-openmpt123 \
+ --disable-examples \
+ $(use_enable test tests) \
+ --disable-doxygen-doc \
+ $(use_with zlib) \
+ $(use_with mp3 mpg123) \
+ $(use_with ogg) \
+ $(use_with vorbis) \
+ $(use_with vorbis vorbisfile) \
+ --without-pulseaudio \
+ --without-portaudio \
+ --without-portaudiocpp \
+ --without-sdl2 \
+ --without-sndfile \
+ --without-flac
+}
+
+multilib_src_install_all() {
+ rm -f \
+ "${ED}"/usr/*/*.la \
+ "${ED}"/usr/share/doc/${P}/LICENSE || die
+
+ if ! use examples; then
+ rm -r "${ED}"/usr/share/doc/${P}/examples || die
+ fi
+}