summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-11-09 10:54:19 +0800
committerYixun Lan <dlan@gentoo.org>2015-11-09 10:54:55 +0800
commitf8d6229bf6baa8dccf3f1dfefb1140cf7993d357 (patch)
tree4b708e0af54dbb20af7a981f3fa92481f5de7673 /media-libs/libde265/libde265-1.0.2.ebuild
parentapp-crypt/eid-mw: add gtk_not_required_4.1.4.patch addressing issue in gentoo... (diff)
downloadgentoo-f8d6229bf6baa8dccf3f1dfefb1140cf7993d357.tar.gz
gentoo-f8d6229bf6baa8dccf3f1dfefb1140cf7993d357.tar.bz2
gentoo-f8d6229bf6baa8dccf3f1dfefb1140cf7993d357.zip
media-libs/libde265: version bump, 1.0.2
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-libs/libde265/libde265-1.0.2.ebuild')
-rw-r--r--media-libs/libde265/libde265-1.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/libde265/libde265-1.0.2.ebuild b/media-libs/libde265/libde265-1.0.2.ebuild
new file mode 100644
index 000000000000..d42d386340ad
--- /dev/null
+++ b/media-libs/libde265/libde265-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="Open h.265 video codec implementation"
+HOMEPAGE="https://github.com/strukturag/libde265"
+SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug qt4 qt5 static-libs cpu_flags_x86_sse tools"
+
+DEPEND="
+ qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 )
+ qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 )
+ media-libs/libsdl
+ virtual/ffmpeg
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="tools? ( || ( qt4 qt5 ) )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable static-libs static)
+ $(use_enable debug log-info)
+ $(use_enable debug log-debug)
+ $(use_enable debug log-trace)
+ $(use_enable tools dec265)
+ $(use_enable tools sherlock265)
+ --disable-silent-rules
+ --enable-log-error
+ )
+ autotools-multilib_src_configure "${myeconfargs[@]}"
+}