summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-01-24 21:38:21 +0100
committerMart Raudsepp <leio@gentoo.org>2024-04-01 22:53:29 +0300
commit5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d (patch)
treecdd57168efdd0079ba10a506ef883bffc6eec65f /media-libs/gst-plugins-good/files/gst-plugins-good-1.22.9-soup-tests-automagic.patch
parentdev-util/ruff: new package, add 0.3.5 (diff)
downloadgentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.tar.gz
gentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.tar.bz2
gentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.zip
media-libs/gstreamer: add 1.22.10, drop 1.22.3 (security)
- eclass / gst-plugins-good: Add "soup" option in the special cases - gst-plugins-good: Backport fix against tests being enabled on libsoup presence automagic-style <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/6058> Closes: https://bugs.gentoo.org/836163 Closes: https://bugs.gentoo.org/908978 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs/gst-plugins-good/files/gst-plugins-good-1.22.9-soup-tests-automagic.patch')
-rw-r--r--media-libs/gst-plugins-good/files/gst-plugins-good-1.22.9-soup-tests-automagic.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/files/gst-plugins-good-1.22.9-soup-tests-automagic.patch b/media-libs/gst-plugins-good/files/gst-plugins-good-1.22.9-soup-tests-automagic.patch
new file mode 100644
index 000000000000..84df443927db
--- /dev/null
+++ b/media-libs/gst-plugins-good/files/gst-plugins-good-1.22.9-soup-tests-automagic.patch
@@ -0,0 +1,71 @@
+From 63322705c878dd391f0fa4c13dd3737d7f1c1aed Mon Sep 17 00:00:00 2001
+From: Nirbheek Chauhan <nirbheek@centricular.com>
+Date: Mon, 5 Feb 2024 22:39:29 +0530
+Subject: [PATCH] good/tests: Don't enable soup tests if soup is disabled
+
+Fixes https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/3268
+
+Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/6058>
+---
+ .../gst-plugins-good/tests/check/meson.build | 24 ++++++++++++-------
+ 1 file changed, 15 insertions(+), 9 deletions(-)
+
+diff --git a/tests/check/meson.build b/tests/check/meson.build
+index 3a4b5c99a67..0871323abcf 100644
+--- a/tests/check/meson.build
++++ b/tests/check/meson.build
+@@ -128,12 +128,6 @@ endif
+ # FIXME: valgrind elements/rtp-payloading - needs fixing
+ # elements/videocrop should be disabled since it takes way too long in valgrind
+
+-libsoup2_dep = dependency('libsoup-2.4', version : '>=2.48',
+- required : false, fallback : ['libsoup', 'libsoup_dep'],
+- default_options: ['sysprof=disabled'])
+-libsoup3_dep = dependency('libsoup-3.0', required : false,
+- fallback : ['libsoup3', 'libsoup_dep'])
+-
+ # FIXME: unistd dependency or not tested yet on windows
+ if host_machine.system() != 'windows'
+ good_tests += [
+@@ -145,8 +139,6 @@ if host_machine.system() != 'windows'
+ [ 'elements/jpegdec', not jpeglib.found() ],
+ [ 'elements/jpegenc', not jpeglib.found() ],
+ [ 'elements/mpg123audiodec', not mpg123_dep.found(), [gstfft_dep]],
+- [ 'elements/souphttpsrc', not libsoup2_dep.found(), [libsoup2_dep], [], 'elements/souphttpsrc2'],
+- [ 'elements/souphttpsrc', not libsoup3_dep.found(), [libsoup3_dep], [], 'elements/souphttpsrc3'],
+ [ 'elements/id3v2mux', not taglib_dep.found() ],
+ [ 'elements/apev2mux', not taglib_dep.found() ],
+ [ 'elements/vp8enc', not vpx_dep.found() or not have_vp8_encoder ],
+@@ -159,6 +151,20 @@ if host_machine.system() != 'windows'
+ ]
+ endif
+
++if get_option('soup').allowed()
++ libsoup3_dep = dependency('libsoup-3.0', required : false,
++ fallback : ['libsoup3', 'libsoup_dep'])
++ libsoup2_dep = dependency('libsoup-2.4', version : '>=2.48',
++ required : false, fallback : ['libsoup', 'libsoup_dep'],
++ default_options: ['sysprof=disabled'])
++
++ if libsoup3_dep.found()
++ good_tests += [['elements/souphttpsrc', false, [libsoup3_dep], []]]
++ elif libsoup2_dep.found()
++ good_tests += [['elements/souphttpsrc', false, [libsoup2_dep], []]]
++ endif
++endif
++
+ test_defines = [
+ '-UG_DISABLE_ASSERT',
+ '-UG_DISABLE_CAST_CHECKS',
+@@ -204,7 +210,7 @@ test_deps = [gst_dep, gstbase_dep, gstnet_dep, gstcheck_dep, gstaudio_dep,
+ # FIXME: add valgrind suppression common/gst.supp gst-plugins-good.supp
+ foreach t : good_tests
+ fname = '@0@.c'.format(t.get(0))
+- test_name = t.get(4, t.get(0)).underscorify()
++ test_name = t.get(0).underscorify()
+ extra_sources = t.get(3, [ ])
+ extra_deps = t.get(2, [ ])
+ skip_test = t.get(1, false)
+--
+GitLab
+