summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-29 21:03:03 +0100
committerSam James <sam@gentoo.org>2022-10-29 21:03:37 +0100
commit8d5482040ac6faa59317a0d51503cd9d0991aed0 (patch)
treea4c36508b2d60647e13fbf7d6f1f4a4274ce31a8 /media-libs/exempi
parentdev-python/pyscreenshot: Keyword 3.0-r1 arm, #858215 (diff)
downloadgentoo-8d5482040ac6faa59317a0d51503cd9d0991aed0.tar.gz
gentoo-8d5482040ac6faa59317a0d51503cd9d0991aed0.tar.bz2
gentoo-8d5482040ac6faa59317a0d51503cd9d0991aed0.zip
media-libs/exempi: add 2.6.2
Bug: https://bugs.gentoo.org/653240 Bug: https://bugs.gentoo.org/764536 Bug: https://bugs.gentoo.org/859841 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/exempi')
-rw-r--r--media-libs/exempi/Manifest1
-rw-r--r--media-libs/exempi/exempi-2.6.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/exempi/Manifest b/media-libs/exempi/Manifest
index 18869996162b..aade23f19cea 100644
--- a/media-libs/exempi/Manifest
+++ b/media-libs/exempi/Manifest
@@ -1 +1,2 @@
DIST exempi-2.4.5.tar.gz 3901474 BLAKE2B 7db80266847a18464ee5d75e2ffa38a05b2b23a30fb02a16c0a4a512f853a625f00db3ee0de3f177af584e12d65c8ecd2acc96cae96ef02d7b39129ab4b5274a SHA512 2b3dd8b2d1763fbbfed1995635f625a8e909a4c3119147385737f349002b2fa038cfaca72b2b877db8f28b9022230e49264b58766a68060b0b7c322cad99b22c
+DIST exempi-2.6.2.tar.bz2 3709476 BLAKE2B 3b65db1f9e7c2bf050af6e273b8327d70e23d3321d3c280ddf8b36b467e2822b12f93cb14d8d342e2a2974a9b745f13fd98c79d9b67e634da5bc9b5ae71e4918 SHA512 c81c7a5bad1a294ce253d1471c00740679b7fb489658ead68a6892b701cc02a031a5dc69d70045a8276e1e19c716df88e92014df4c2809266a71ff05de9ad57a
diff --git a/media-libs/exempi/exempi-2.6.2.ebuild b/media-libs/exempi/exempi-2.6.2.ebuild
new file mode 100644
index 000000000000..9ce6104f4934
--- /dev/null
+++ b/media-libs/exempi/exempi-2.6.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
+# TODO: switch to xz for 2.6.3
+SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="2/8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/expat-2:=
+ sys-libs/zlib
+ virtual/libiconv
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-libs/boost )
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.2-iconv.patch
+)
+
+src_prepare() {
+ default
+
+ config_rpath_update .
+ eautoreconf
+}
+
+src_configure() {
+ # Valgrind detection is "disabled" due to bug #295875
+ econf \
+ $(use_enable test unittest) \
+ VALGRIND=""
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm samples/{,source,testfiles}/Makefile* || die
+ docinto examples
+ dodoc -r samples/.
+ fi
+
+ # --disable-static breaks tests
+ rm -rf "${ED}/usr/$(get_libdir)/libexempi.a" || die
+
+ find "${ED}" -name '*.la' -delete || die
+}