summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/devil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/devil')
-rw-r--r--media-libs/devil/Manifest1
-rw-r--r--media-libs/devil/devil-1.7.8-r2.ebuild78
-rw-r--r--media-libs/devil/files/devil-1.7.8-CVE-2009-3994.patch17
-rw-r--r--media-libs/devil/files/devil-1.7.8-ILUT.patch17
-rw-r--r--media-libs/devil/files/devil-1.7.8-libpng14.patch33
-rw-r--r--media-libs/devil/files/devil-1.7.8-nvtt-glut.patch83
-rw-r--r--media-libs/devil/metadata.xml12
7 files changed, 241 insertions, 0 deletions
diff --git a/media-libs/devil/Manifest b/media-libs/devil/Manifest
new file mode 100644
index 000000000000..8a251b76c864
--- /dev/null
+++ b/media-libs/devil/Manifest
@@ -0,0 +1 @@
+DIST DevIL-1.7.8.tar.gz 2051993 SHA256 682ffa3fc894686156337b8ce473c954bf3f4fb0f3ecac159c73db632d28a8fd SHA512 a67e1488d6cb366431d9fcb460b8fe5b8a1dd79426ac77f8abd0db4a5aad7512697f72ef0c49ddb0e806469cc37ba1319e10ccd2ebd73942332df2c3c507458e WHIRLPOOL 749bf0ce73786709414d6f2c3bf29b20c56397cb6f9f92b4158902a98a4f4d0ef66d78096ce8daea3d65b1718c5255421055cd223e9269f6c773ca310c2df146
diff --git a/media-libs/devil/devil-1.7.8-r2.ebuild b/media-libs/devil/devil-1.7.8-r2.ebuild
new file mode 100644
index 000000000000..1f03c571c27a
--- /dev/null
+++ b/media-libs/devil/devil-1.7.8-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=DevIL-${PV}
+
+DESCRIPTION="DevIL image library"
+HOMEPAGE="http://openil.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openil/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~mips ppc ~ppc64 x86"
+IUSE="allegro gif glut jpeg jpeg2k mng nvtt openexr opengl png sdl cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 static-libs tiff xpm X"
+
+RDEPEND="allegro? ( media-libs/allegro:0 )
+ gif? ( media-libs/giflib )
+ glut? ( media-libs/freeglut )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/jasper )
+ mng? ( media-libs/libmng )
+ nvtt? ( media-gfx/nvidia-texture-tools )
+ openexr? ( media-libs/openexr )
+ opengl? ( virtual/opengl
+ virtual/glu )
+ png? ( media-libs/libpng:0 )
+ sdl? ( media-libs/libsdl )
+ tiff? ( media-libs/tiff:0 )
+ xpm? ( x11-libs/libXpm )
+ X? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXrender )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ X? ( x11-proto/xextproto )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{CVE-2009-3994,libpng14,nvtt-glut,ILUT}.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-lcms \
+ --enable-ILU \
+ --enable-ILUT \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable openexr exr) \
+ $(use_enable gif) \
+ $(use_enable jpeg) \
+ $(use_enable jpeg2k jp2) \
+ $(use_enable mng) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_enable xpm) \
+ $(use_enable allegro) \
+ --disable-directx8 \
+ --disable-directx9 \
+ $(use_enable opengl) \
+ $(use_enable sdl) \
+ $(use_enable X x11) \
+ $(use_enable X shm) \
+ $(use_enable X render) \
+ $(use_enable glut) \
+ $(use_with X x) \
+ $(use_with nvtt)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
diff --git a/media-libs/devil/files/devil-1.7.8-CVE-2009-3994.patch b/media-libs/devil/files/devil-1.7.8-CVE-2009-3994.patch
new file mode 100644
index 000000000000..6c9f2db1d270
--- /dev/null
+++ b/media-libs/devil/files/devil-1.7.8-CVE-2009-3994.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/297760
+
+--- src-IL/src/il_dicom.c
++++ src-IL/src/il_dicom.c
+@@ -427,9 +427,11 @@ ILboolean GetUID(ILubyte *UID)
+ return IL_FALSE;
+
+ ValLen = GetLittleUShort();
++ if (ValLen > 64)
++ return IL_FALSE;
+ if (iread(UID, ValLen, 1) != 1)
+ return IL_FALSE;
+- UID[64] = 0; // Just to make sure that our string is terminated.
++ UID[ValLen] = 0; // Just to make sure that our string is terminated.
+
+ return IL_TRUE;
+ }
diff --git a/media-libs/devil/files/devil-1.7.8-ILUT.patch b/media-libs/devil/files/devil-1.7.8-ILUT.patch
new file mode 100644
index 000000000000..7807d0eac2e6
--- /dev/null
+++ b/media-libs/devil/files/devil-1.7.8-ILUT.patch
@@ -0,0 +1,17 @@
+From: hasufell <hasufell@gentoo.org>
+Date: Thu May 3 22:23:21 UTC 2012
+
+use_x11=no was not set when --disable-x11 was
+
+--- m4/devil-api_checks.m4
++++ m4/devil-api_checks.m4
+@@ -137,7 +137,8 @@
+ [main],
+ [dnl The use_x11 var is either "yes" already, or we don't want "no" to be overwritten
+ ILUT_LIBS="-lX11 $ILUT_LIBS"],
+- [use_x11="no"]) ])
++ [use_x11="no"]) ],
++ [use_x11="no"])
+ TEST_API([shm])
+ AS_IF([test "x$enable_shm" = "xyes"],
+ [AC_CHECK_HEADER([X11/extensions/XShm.h],
diff --git a/media-libs/devil/files/devil-1.7.8-libpng14.patch b/media-libs/devil/files/devil-1.7.8-libpng14.patch
new file mode 100644
index 000000000000..b8434692b8bd
--- /dev/null
+++ b/media-libs/devil/files/devil-1.7.8-libpng14.patch
@@ -0,0 +1,33 @@
+diff -Nur devil-1.7.8.orig/src-IL/src/il_icon.c devil-1.7.8/src-IL/src/il_icon.c
+--- devil-1.7.8.orig/src-IL/src/il_icon.c 2009-03-08 09:10:09.000000000 +0200
++++ devil-1.7.8/src-IL/src/il_icon.c 2010-01-17 00:54:09.000000000 +0200
+@@ -525,7 +525,7 @@
+
+ // Expand low-bit-depth grayscale images to 8 bits
+ if (ico_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
+- png_set_gray_1_2_4_to_8(ico_png_ptr);
++ png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
+ }
+
+ // Expand RGB images with transparency to full alpha channels
+diff -Nur devil-1.7.8.orig/src-IL/src/il_png.c devil-1.7.8/src-IL/src/il_png.c
+--- devil-1.7.8.orig/src-IL/src/il_png.c 2009-03-08 09:10:09.000000000 +0200
++++ devil-1.7.8/src-IL/src/il_png.c 2010-01-17 00:55:26.000000000 +0200
+@@ -105,7 +105,7 @@
+ Read = iread(Signature, 1, 8);
+ iseek(-Read, IL_SEEK_CUR);
+
+- return png_check_sig(Signature, 8);
++ return png_sig_cmp(Signature, 0, 8) == 0;
+ }
+
+
+@@ -278,7 +278,7 @@
+
+ // Expand low-bit-depth grayscale images to 8 bits
+ if (png_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ // Expand RGB images with transparency to full alpha channels
diff --git a/media-libs/devil/files/devil-1.7.8-nvtt-glut.patch b/media-libs/devil/files/devil-1.7.8-nvtt-glut.patch
new file mode 100644
index 000000000000..8e2ccd74e18e
--- /dev/null
+++ b/media-libs/devil/files/devil-1.7.8-nvtt-glut.patch
@@ -0,0 +1,83 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue May 1 20:00:44 UTC 2012
+Subject: build system
+
+remove automagic handling of glut and add configure option
+fix "header present but cannot be compiled" warning for nvtt
+
+--- m4/ax_check_glut.m4
++++ m4/ax_check_glut.m4
+@@ -114,4 +114,11 @@
+
+ AC_SUBST([GLUT_CFLAGS])
+ AC_SUBST([GLUT_LIBS])
++
++AC_ARG_ENABLE([glut],
++ [AS_HELP_STRING([--enable-glut],
++ [Enable support for glut (default=yes)]) ],
++ [enable_glut=$enableval],
++ [enable_glut="yes"])
++
+ ])dnl
+--- m4/devil-api_checks.m4
++++ m4/devil-api_checks.m4
+@@ -31,8 +31,8 @@
+ AS_IF([test "x$no_gl" != "xyes" -a "x$no_glu" != "xyes"],
+ [use_ogl="yes"
+ ILUT_LIBS="$GLU_LIBS $GL_LIBS $ILUT_LIBS"
+- AS_IF([test "x$no_glut" != "xyes"],
+- [have_glut="yes"
++ AS_IF([test "x$no_glut" != "xyes" -a "x$enable_glut" = "xyes"],
++ [use_glut="yes"
+ ILUT_LIBS="$GLUT_LIBS $ILUT_LIBS"])
+ AC_DEFINE([ILUT_USE_OPENGL],
+ [1],
+--- configure.ac
++++ configure.ac
+@@ -343,8 +343,10 @@
+ [Do you want to use the Nvidia texture tools if possible? (enables GPU accelerated image manipulation, default="yes")]) ],
+ [],
+ [with_nvtt="yes"])
++AC_LANG_PUSH([C++])
+ AS_IF([test "x$with_nvtt" = "xyes"],
+ [DEVIL_CHECK_NVIDIA_TEXTOOLS])
++AC_LANG_POP
+
+ dnl
+ dnl ILUT APIs library checking
+@@ -392,8 +394,8 @@
+ AM_CONDITIONAL([USE_OPENGL],
+ [test "x$use_ogl" = "xyes"])
+
+-AM_CONDITIONAL([HAVE_GLUT],
+- [test "x$have_glut" = "xyes"])
++AM_CONDITIONAL([USE_GLUT],
++ [test "x$use_glut" = "xyes"])
+
+ AM_CONDITIONAL([USE_SDL],
+ [test "x$use_sdl" = "xyes"])
+@@ -410,7 +412,7 @@
+ AM_CONDITIONAL([USE_X11],
+ [test "x$use_x11" = "xyes"])
+ #this is instedad AM_COND_IF([USE_OPENGL && USE_X11])
+-AS_IF([test "x$have_glut" = "xyes" -a "x$use_x11" = "xyes"],
++AS_IF([test "x$use_glut" = "xyes" -a "x$use_x11" = "xyes"],
+ [EXAMPLES_TO_BUILD="$EXAMPLES_TO_BUILD ILUT_gl ILUT_volume"])
+
+ dnl Win32
+--- bin/Makefile.am
++++ bin/Makefile.am
+@@ -45,11 +45,11 @@
+ examples_PROGRAMS += ILUT_animation
+ endif #USE_W32
+
+-if HAVE_GLUT
++if USE_GLUT
+ if USE_X11
+ examples_PROGRAMS += ILUT_gl ILUT_volume
+ endif #USE_X11
+-endif #HAVE_GLUT
++endif #USE_GLUT
+
+ endif #BUILD_ILUT
+
diff --git a/media-libs/devil/metadata.xml b/media-libs/devil/metadata.xml
new file mode 100644
index 000000000000..30db632a5379
--- /dev/null
+++ b/media-libs/devil/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="allegro">Add support for Allegro</flag>
+ <flag name="nvtt">Add support for <pkg>dev-util/nvidia-texture-tools</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">openil</remote-id>
+ </upstream>
+</pkgmetadata>