summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Clayton <stillcompiling@gmail.com>2016-06-06 02:32:52 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-06 02:33:54 +1000
commit937a0fe10289f67201f7384ef57b0a833e9a1cea (patch)
tree423e7b93193058ca3d8de823e8ce1dede0595c95 /media-libs/alure
parentprofiles: disable >=net-print/hplip-3.16.5 -qt4 in plasma (diff)
downloadgentoo-937a0fe10289f67201f7384ef57b0a833e9a1cea.tar.gz
gentoo-937a0fe10289f67201f7384ef57b0a833e9a1cea.tar.bz2
gentoo-937a0fe10289f67201f7384ef57b0a833e9a1cea.zip
media-libs/alure: add patch to fix build with USE="fluidsynth"
Gentoo-bug: 500164 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-libs/alure')
-rw-r--r--media-libs/alure/alure-1.2.ebuild5
-rw-r--r--media-libs/alure/files/alure-1.2-include-unistd.patch13
2 files changed, 16 insertions, 2 deletions
diff --git a/media-libs/alure/alure-1.2.ebuild b/media-libs/alure/alure-1.2.ebuild
index 3d694ae99770..8f07f4e81ab0 100644
--- a/media-libs/alure/alure-1.2.ebuild
+++ b/media-libs/alure/alure-1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
-inherit cmake-utils
+inherit cmake-utils eutils
DESCRIPTION="The OpenAL Utility Toolkit"
HOMEPAGE="http://kcat.strangesoft.net/alure.html"
@@ -24,6 +24,7 @@ RDEPEND=">=media-libs/openal-1.1
DEPEND="${RDEPEND}"
src_prepare() {
+ epatch "${FILESDIR}/${P}-include-unistd.patch"
sed -i -e "/DESTINATION/s:doc/alure:doc/${PF}:" CMakeLists.txt || die
}
diff --git a/media-libs/alure/files/alure-1.2-include-unistd.patch b/media-libs/alure/files/alure-1.2-include-unistd.patch
new file mode 100644
index 000000000000..b2db3dc30fa4
--- /dev/null
+++ b/media-libs/alure/files/alure-1.2-include-unistd.patch
@@ -0,0 +1,13 @@
+Gentoo-bug: 500164
+
+--- a/src/codec_fluidsynth.cpp
++++ b/src/codec_fluidsynth.cpp
+@@ -30,6 +30,8 @@
+ #ifdef _WIN32
+ #include <io.h>
++#else
++#include <unistd.h>
+ #endif
+
+ #include <istream>
+