summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-10 20:39:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-10 20:55:13 +0200
commitd7106ab701503af4b5efbe7277b2d2353b9d140d (patch)
treecf08ec4f5631cda0746b12fca8753ae6357b86d1 /media-gfx
parentmedia-gfx/kio-mobi-thumbnailer: 24.08.2 version bump (diff)
downloadgentoo-d7106ab701503af4b5efbe7277b2d2353b9d140d.tar.gz
gentoo-d7106ab701503af4b5efbe7277b2d2353b9d140d.tar.bz2
gentoo-d7106ab701503af4b5efbe7277b2d2353b9d140d.zip
media-gfx/kio-ps-thumbnailer: 24.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/kio-ps-thumbnailer/Manifest1
-rw-r--r--media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/kio-ps-thumbnailer/Manifest b/media-gfx/kio-ps-thumbnailer/Manifest
index 4ef509f2e40c..e6360ba2c297 100644
--- a/media-gfx/kio-ps-thumbnailer/Manifest
+++ b/media-gfx/kio-ps-thumbnailer/Manifest
@@ -1,3 +1,4 @@
DIST kdegraphics-thumbnailers-23.08.5.tar.xz 49436 BLAKE2B 943ad7bd93ca5e4d80854869d4d97f7121d259a82062afb7781d1845e94cbc6ea1732aff3d3476eb6db5ffe54f8f97b352ef8977ebdccc2b173594dd3cbccd6f SHA512 77c328e9532fbd12548d4d219d6da2ad369ee14825d3cf5d142ec11afb842640e1fd01e7e1f911147c93e7e93893b9ae10be66b3d568866ed8985b5e5b38663f
DIST kdegraphics-thumbnailers-24.05.2.tar.xz 48756 BLAKE2B f5c2932c89fe38933c764171c31edfc0c11b7d6a34170e283a5f7ebc221866a2005897e580f1076b4a8bd9438d2fc39ff4b5da99abe90ce41c7465f35b7f6479 SHA512 eafc1eaf48fe7fef2556b1ba39beec0032b3fbc3ad01856517c86e6d56a2d24c488db9ca6cd9669a5b70c16ce44b6006c0a9e48216af08d03fbd805973158503
DIST kdegraphics-thumbnailers-24.08.1.tar.xz 49016 BLAKE2B 1c29734d1371f970271e9bf0dd0750d80f5c19b78c7cdb90bc0665ee748cf4aa0414047796d96b21c207b3f6071e0e3a5fb83126d0f4f919793070f335180457 SHA512 d1b15005e080581ce31d96271bf8827a969ef95b3703ec80858b2d26fc5dd615d408471065647e0d7b7fef39b9e9af18fcf1af56594be13df5f3119fa81c2134
+DIST kdegraphics-thumbnailers-24.08.2.tar.xz 49096 BLAKE2B 3c6eddf3abe61ca55ffe04dda9e720be324078bf453b2c768ed001490e19b5c8df5d4904c14d4f82a96d9fc669cae5956f673a6aa81591044fa8f40695e594eb SHA512 0d9c536865702e0e1962cf7405373a2166656f9b63fdd03128000b2aac01fceceb1b9ddea041fbc6c66d79a744b76575929896fe1614b060941eb56ae69fa0f1
diff --git a/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild
new file mode 100644
index 000000000000..e0ab87727184
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for DVI, EPS, PDF and PS files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=kde-frameworks/kio-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-24.05.2-r1:6
+ app-text/dvipsk
+ app-text/ghostscript-gpl
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_blend=OFF
+ -DDISABLE_MOBIPOCKET=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_QMobipocket6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KExiv2Qt6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDcrawQt6=ON
+ )
+
+ ecm_src_configure
+}