summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-03 23:03:16 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-03 23:17:41 -0500
commit7d5aaaf5062d9b51471218e66aabf398c203f699 (patch)
tree2742b34ff5d4458d93e610e6fed1d25bbec3c543 /media-gfx/ueberzug/ueberzug-18.3.0.ebuild
parentapp-shells/fzf: Stabilize 0.55.0 amd64, #942849 (diff)
downloadgentoo-7d5aaaf5062d9b51471218e66aabf398c203f699.tar.gz
gentoo-7d5aaaf5062d9b51471218e66aabf398c203f699.tar.bz2
gentoo-7d5aaaf5062d9b51471218e66aabf398c203f699.zip
media-gfx/ueberzug: add 18.3.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/ueberzug/ueberzug-18.3.0.ebuild')
-rw-r--r--media-gfx/ueberzug/ueberzug-18.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/ueberzug/ueberzug-18.3.0.ebuild b/media-gfx/ueberzug/ueberzug-18.3.0.ebuild
new file mode 100644
index 000000000000..6aba22f549c7
--- /dev/null
+++ b/media-gfx/ueberzug/ueberzug-18.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Command line util to draw images on terminals by using child windows"
+HOMEPAGE="https://github.com/ueber-devel/ueberzug/"
+SRC_URI="
+ https://github.com/ueber-devel/ueberzug/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXres
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ !media-gfx/ueberzugpp
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+
+distutils_enable_tests import-check