summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/symboleditor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/symboleditor')
-rw-r--r--media-gfx/symboleditor/Manifest1
-rw-r--r--media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch25
-rw-r--r--media-gfx/symboleditor/metadata.xml5
-rw-r--r--media-gfx/symboleditor/symboleditor-1.5.0.ebuild26
4 files changed, 57 insertions, 0 deletions
diff --git a/media-gfx/symboleditor/Manifest b/media-gfx/symboleditor/Manifest
new file mode 100644
index 000000000000..e7a76816255f
--- /dev/null
+++ b/media-gfx/symboleditor/Manifest
@@ -0,0 +1 @@
+DIST SymbolEditor-1.5.0-1.tar.bz2 779158 SHA256 707da2874dcd08101b218b7a60f1ec3ed5ba056d6221a1dd472821737c545db0 SHA512 5fe18b649ed78e6ab3c61ce80a0b159941a65065801cdc6a44f1187aa40a2816cbc7888ea9e120cad8089e3e8e7831cedfd3242de5092cea58eb5cf898de022c WHIRLPOOL b3219bd30fbf993b7bd1c998e068e9f462ce312d0e6038b7706324b15810a9a1933ddedf39e6c33ac92deb2d38802807c1c3094fd1733321248b4362a22749e5
diff --git a/media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch b/media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch
new file mode 100644
index 000000000000..177fd180d56a
--- /dev/null
+++ b/media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch
@@ -0,0 +1,25 @@
+From a495671be994a32f4b52840f7e5c358916a378dc Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Tue, 26 Aug 2014 20:17:22 +1000
+Subject: [PATCH] Respect user-defined CFLAGS.
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3166676..50786be 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -43,7 +43,7 @@ kde4_add_executable (SymbolEditor ${SymbolEditor_SRCS})
+
+ target_link_libraries (SymbolEditor ${KDE4_KDEUI_LIBS} ${KDE4_KIO_LIBS})
+
+-set (CMAKE_CXX_FLAGS "-DQT_NO_COMPAT -DKDE_NO_COMPAT")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexceptions -DQT_NO_COMPAT -DKDE_NO_COMPAT")
+
+ install (TARGETS SymbolEditor DESTINATION ${BIN_INSTALL_DIR})
+ install (FILES SymbolEditorui.rc DESTINATION ${DATA_INSTALL_DIR}/SymbolEditor)
+--
+1.8.5.5
+
diff --git a/media-gfx/symboleditor/metadata.xml b/media-gfx/symboleditor/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/media-gfx/symboleditor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/media-gfx/symboleditor/symboleditor-1.5.0.ebuild b/media-gfx/symboleditor/symboleditor-1.5.0.ebuild
new file mode 100644
index 000000000000..489a18bf0450
--- /dev/null
+++ b/media-gfx/symboleditor/symboleditor-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_DOC_DIRS="doc-translations/%lingua_${PN}"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="ca cs da de en_GB es et lt nl pl pt pt_BR sk sv uk"
+MY_P="SymbolEditor-${PV}"
+inherit kde4-base
+
+DESCRIPTION="Program to create libraries of QPainterPath objects with hints on how to render them"
+HOMEPAGE="http://userbase.kde.org/SymbolEditor"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${MY_P}-1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-cflags.patch" )