summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@fastmail.com>2017-08-16 21:51:33 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2017-10-03 02:34:29 -0400
commit5c2f1337a48523c475f90f7eb2bf1b43610e4215 (patch)
tree21a8fd96f4671bdc8b5c27104eceb9882e5ee7de /media-gfx/propaganda
parentdev-ruby/flexmock: add 2.3.6 (diff)
downloadgentoo-5c2f1337a48523c475f90f7eb2bf1b43610e4215.tar.gz
gentoo-5c2f1337a48523c475f90f7eb2bf1b43610e4215.tar.bz2
gentoo-5c2f1337a48523c475f90f7eb2bf1b43610e4215.zip
media-gfx/propaganda: add 1.0-r1 for improvements and fixes
This is to facilitate maintenance such as update to EAPI=6 and fixes the issues highlighted by repoman and more. - add quotes around strings with variables - fix LICENSE Actual COPYING files are saying the license is GPLv2 or any later version. - omit COPYING, README-GPL from dodoc These files contain GPLv2+ license text which shouldn't be installed as it is already indicated by LICENSE in ebuild. - replace dead homepage URL with No_homepage - use mirror://gentoo/ in SRC_URI SRC_URI contained URLs which don't work anymore, distfiles are being fetched from mirrors anyway. - install just jpg files and doc, simplify ebuild Unnecessary files which were installed by 1.0 ebuild, listed below, are no more shipped. This allowed to simplify ebuild logic. HTML files for viewing of image files and navigation between them. They are deemed not essential. README: contained nothing more than an author's suggestion to view images directories in KDE. README-PROPAGANDA, which contains a substantial introduction into project history, is still installed. magicbg.tar{,.gz}: source code of some app, not essential for usage of the package. script.perl: scripts for generation of navigation HTML. More non-essential files, e.g. /usr/share/pixmaps/Propaganda/Vol11/Icon:0d /usr/share/pixmaps/Propaganda/Vol11/Modified by Michael Coyle /usr/share/pixmaps/Propaganda/Vol12/Icon:0d - use prepare phase for renames Renaming (volume dir names, *.JPG to *.jpg) is not really compiling, so use src_prepare phase which is designed for actions like these. - add "|| die" to commands which may fail Suggested-by: Amy Liffey <amynka@gentoo.org> Suggested-by: Göktürk Yüksek <gokturk@gentoo.org> Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'media-gfx/propaganda')
-rw-r--r--media-gfx/propaganda/propaganda-1.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/propaganda/propaganda-1.0-r1.ebuild b/media-gfx/propaganda/propaganda-1.0-r1.ebuild
new file mode 100644
index 000000000000..86f584a1d5f7
--- /dev/null
+++ b/media-gfx/propaganda/propaganda-1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+S="${WORKDIR}/Propaganda"
+DESCRIPTION="Propaganda Volume 1-14 + E. Tiling images for your desktop"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SITE="mirror://gentoo/"
+SRC_URI="${SITE}Propaganda-Vol-01.tar.gz
+ ${SITE}Propaganda-Vol-02.tar.gz
+ ${SITE}Propaganda-Vol-03.tar.gz
+ ${SITE}Propaganda-Vol-04.tar.gz
+ ${SITE}Propaganda-Vol-05.tar.gz
+ ${SITE}Propaganda-Vol-06.tar.gz
+ ${SITE}Propaganda-Vol-07.tar.gz
+ ${SITE}Propaganda-Vol-08.tar.gz
+ ${SITE}Propaganda-Vol-09.tar.gz
+ ${SITE}Propaganda-Vol-10.tar.gz
+ ${SITE}Propaganda-Vol-11.tar.gz
+ ${SITE}Propaganda-Vol-12.tar.gz
+ ${SITE}Propaganda-13.tar.gz
+ ${SITE}Propaganda-14.tar.gz
+ ${SITE}Propaganda-For-E.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+
+ mv ../Propaganda-Vol-11 Vol11 || die
+ mv ../Propaganda-Vol-12 Vol12 || die
+
+ rename JPG jpg */*.JPG || die
+}
+
+src_install() {
+ dodoc README-PROPAGANDA
+
+ local VOLUME
+ for VOLUME in Vol* Propaganda-For-E; do
+ insinto "/usr/share/pixmaps/Propaganda/${VOLUME}"
+ doins "${VOLUME}"/*.jpg
+ done
+}