summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-19 21:23:41 +0000
committerSam James <sam@gentoo.org>2020-09-19 21:24:16 +0000
commit226a0725ccc8ebe63bdb79676c9873d8fe40e714 (patch)
tree7208618a9dc18253910d89926e74f5120a6e4ee5 /media-gfx/mypaint
parentdev-vcs/hg-evolve: version bumps (diff)
downloadgentoo-226a0725ccc8ebe63bdb79676c9873d8fe40e714.tar.gz
gentoo-226a0725ccc8ebe63bdb79676c9873d8fe40e714.tar.bz2
gentoo-226a0725ccc8ebe63bdb79676c9873d8fe40e714.zip
media-gfx/mypaint: cleanup old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/mypaint')
-rw-r--r--media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch37
-rw-r--r--media-gfx/mypaint/mypaint-2.0.1.ebuild69
2 files changed, 0 insertions, 106 deletions
diff --git a/media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch b/media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch
deleted file mode 100644
index c7806e7119dc..000000000000
--- a/media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 670df4d..703f9d2 100644
---- a/setup.py
-+++ b/setup.py
-@@ -471,9 +471,6 @@ class BuildExt (build_ext):
- linkflags.extend([
- "-O0",
- ])
-- else:
-- linkflags.append("-O3")
-- ccflags.append("-O3")
-
- return build_ext.build_extension(self, ext)
-
-@@ -869,7 +866,6 @@ def get_ext_modules():
- '-Wno-write-strings',
- '-D_POSIX_C_SOURCE=200809L',
- "-DNO_TESTS", # FIXME: we're building against shared libmypaint now
-- '-g', # always include symbols, for profiling
- ]
- extra_link_args = []
-
-diff --git a/setup.py b/setup.py
-index 703f9d2..cc8abbd 100644
---- a/setup.py
-+++ b/setup.py
-@@ -456,10 +456,6 @@ class BuildExt (build_ext):
- ccflags = ext.extra_compile_args
- linkflags = ext.extra_link_args
-
-- if sys.platform != "darwin" and not self.disable_openmp:
-- linkflags.append(OPENMP_CFLAG)
-- ccflags.append(OPENMP_LDFLAG)
--
- if self.debug:
- skip = ["-DNDEBUG"]
- ccflags[:] = [f for f in ccflags if f not in skip]
diff --git a/media-gfx/mypaint/mypaint-2.0.1.ebuild b/media-gfx/mypaint/mypaint-2.0.1.ebuild
deleted file mode 100644
index 1ca2e261568c..000000000000
--- a/media-gfx/mypaint/mypaint-2.0.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit desktop distutils-r1 xdg
-
-DESCRIPTION="Fast and easy graphics application for digital painters"
-HOMEPAGE="http://mypaint.org/"
-SRC_URI="https://github.com/mypaint/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-LANGS="cs de en_CA en_GB es fr hu id it ja ko nb nn_NO pl pt_BR ro ru sl sv uk zh_CN zh_TW"
-
-BDEPEND="
- ${PYTHON_DEPS}
- dev-lang/swig
- sys-devel/gettext
- virtual/pkgconfig
-"
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pycairo-1.4[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- ')
- >=dev-libs/json-c-0.11:=
- gnome-base/librsvg
- media-gfx/mypaint-brushes:2.0
- media-libs/lcms:2
- >=media-libs/libmypaint-1.5.0
- media-libs/libpng:0=
- sys-devel/gettext
- sys-libs/libomp
- x11-libs/gtk+:3
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.0.1-build-system.patch"
-)
-
-distutils_enable_tests setup.py
-
-# TODO: Allow openmp support (patched out)
-# There's no urgency on this given that it currently
-# breaks runtime use [0]
-# [0] https://github.com/mypaint/mypaint/issues/1107.
-
-src_install() {
- distutils-r1_src_install
-
- newicon pixmaps/${PN}_logo.png ${PN}.png
-
- local lang=
- for lang in ${LANGS}; do
- if ! has ${lang} ${LINGUAS}; then
- rm -rf "${ED}"/usr/share/locale/${lang} || die
- fi
- done
-}