summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2023-02-25 19:48:10 +0300
committerMichał Górny <mgorny@gentoo.org>2023-02-26 04:59:52 +0100
commit6472bedae5a9dd360bb02793043fd93e8635ae87 (patch)
tree036d4e5f469c7fa49991dec82dd68df39f62e0da /media-gfx/hydrus
parentmedia-gfx/hydrus: Drop 515 (diff)
downloadgentoo-6472bedae5a9dd360bb02793043fd93e8635ae87.tar.gz
gentoo-6472bedae5a9dd360bb02793043fd93e8635ae87.tar.bz2
gentoo-6472bedae5a9dd360bb02793043fd93e8635ae87.zip
media-gfx/hydrus: Add 518, 9999 with support for python 3.11
Closes: https://bugs.gentoo.org/896986 Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Closes: https://github.com/gentoo/gentoo/pull/29790 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/hydrus')
-rw-r--r--media-gfx/hydrus/Manifest2
-rw-r--r--media-gfx/hydrus/hydrus-518.ebuild152
-rw-r--r--media-gfx/hydrus/hydrus-9999.ebuild10
3 files changed, 161 insertions, 3 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index 9156132cd366..37c23f2511ad 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -1 +1,3 @@
+DIST hydrus-3.11-test-fixes.patch 8493 BLAKE2B 598c9a82ced8c181ac2c9f91bef34ad9136444f40d909a69c0c0d3a5f620bb2818a684ed221ae62f1e6226d6b534b6ac06cedb3f65a5f3be8fc2b12612a9daad SHA512 6dd8206b02f5f209cf86d2b8cd65952cc3d449352d3cb91c654d325077306415e6482191a4e64cba6aec2c4f1ff358c01e2ecbe7d3b56c9027673757a3590051
DIST hydrus-516.tar.gz 41098992 BLAKE2B 4195ade87f9f42f5aaf592ae502e49404d3fb188f7921c137973e7df31af8bb346c243a375e99014cfa9e3d6821a187b254cfe79f88c470cf54aa45e50e9bb22 SHA512 941cb81fba305708a1c33250aae366ae3bf8ba83d9aab90475bec09109608c86b68fdcc84d18a4fe324f57b2b91b8531887d9792b9d9130c5234f9cfa96e106f
+DIST hydrus-518.tar.gz 41105373 BLAKE2B e766cdb7e8ffdc1148f5970724a6d3293522a0ae750c4e5c996d5cdbabc837dc3a9c002251080b6253a869b2cf87a17cb9c7b99ad912d68b6b5c4207e1d3ae7a SHA512 7e551ba83e97b490c98bf1858b87c78e9d5564cfaecfc83426ad2d802005e7cb84c9aadc61b762f3dca1916b8e786ca044bb310c93462e4c4f953f60f3291ed2
diff --git a/media-gfx/hydrus/hydrus-518.ebuild b/media-gfx/hydrus/hydrus-518.ebuild
new file mode 100644
index 000000000000..072c47dfe381
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-518.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+DOCS_BUILDER=mkdocs
+DOCS_DEPEND="dev-python/mkdocs-material dev-python/regex"
+
+inherit python-single-r1 desktop docs optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+ SRC_URI="https://github.com/vaartis/hydrus/commit/106a55b3aca945d047685eb53bd1d2aa8b8a7c50.diff -> ${PN}-3.11-test-fixes.patch"
+else
+ SRC_URI="
+ https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vaartis/hydrus/commit/106a55b3aca945d047685eb53bd1d2aa8b8a7c50.diff -> ${PN}-3.11-test-fixes.patch
+ "
+
+ KEYWORDS="~amd64"
+fi
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+# RDEPEND is sorted as such:
+# - No specific requirements
+# - Specific version or slot
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/cbor2[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cloudscraper[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyside2[widgets,gui,${PYTHON_USEDEP}]
+ dev-python/python-mpv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
+ media-video/ffmpeg
+
+ >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/userpath-in-local-share.patch"
+ "${DISTDIR}/${PN}-3.11-test-fixes.patch"
+)
+
+src_prepare() {
+ default
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Build files used for CI and development, not actually needed
+ rm -r static/build_files static/requirements || die
+ # Python requirements file, not needed
+ rm requirements.txt || die
+ # Remove unneeded additional scripts
+ rm *.command *.sh *.bat || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+ docs_compile
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ local -x QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+}
+
+src_install() {
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${doc}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
+ einstalldocs
+
+ # Files only needed for testing
+ rm test.py hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ static/testing/ || die
+
+ # ${DOCS[@]} files are copied into doc
+ # ${S}/docs/ is the markdown source code for documentation
+ # .gitignore/.github files aren't needed for the program to work, same with mkdocs files
+ rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
+ if use doc; then
+ # ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
+ rm -r "${S}/_build" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ dosym "${doc}/html" /opt/hydrus/help
+ fi
+
+ insinto /opt/hydrus
+ doins -r "${S}"/.
+
+ exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" || die)
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" || die)
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "automatic port forwarding support" "net-libs/miniupnpc"
+ optfeature "bandwidth charts support" "dev-python/pyside2[charts]"
+ optfeature "memory compression in the client" "dev-python/lz4"
+ optfeature "SOCKS proxy support" "dev-python/requests[socks5]" "dev-python/PySocks"
+}
diff --git a/media-gfx/hydrus/hydrus-9999.ebuild b/media-gfx/hydrus/hydrus-9999.ebuild
index e447f565f37b..072c47dfe381 100644
--- a/media-gfx/hydrus/hydrus-9999.ebuild
+++ b/media-gfx/hydrus/hydrus-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="sqlite"
DOCS_BUILDER=mkdocs
@@ -18,8 +18,12 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+ SRC_URI="https://github.com/vaartis/hydrus/commit/106a55b3aca945d047685eb53bd1d2aa8b8a7c50.diff -> ${PN}-3.11-test-fixes.patch"
else
- SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vaartis/hydrus/commit/106a55b3aca945d047685eb53bd1d2aa8b8a7c50.diff -> ${PN}-3.11-test-fixes.patch
+ "
KEYWORDS="~amd64"
fi
@@ -58,7 +62,6 @@ RDEPEND="
dev-python/twisted[${PYTHON_USEDEP}]
media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
media-video/ffmpeg
- media-video/mpv[libmpv,${PYTHON_USEDEP}]
>=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
@@ -76,6 +79,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/userpath-in-local-share.patch"
+ "${DISTDIR}/${PN}-3.11-test-fixes.patch"
)
src_prepare() {