summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-03 03:56:31 +0100
committerSam James <sam@gentoo.org>2024-08-03 03:56:31 +0100
commit3db506579f0478f32a6a3acf8036e0473e801a9f (patch)
tree521ae2acea73fca0680d2a9c205bf03887ac9116 /media-gfx/graphite2
parentdev-cpp/cppdap: add 0_pre20240802 (diff)
downloadgentoo-3db506579f0478f32a6a3acf8036e0473e801a9f.tar.gz
gentoo-3db506579f0478f32a6a3acf8036e0473e801a9f.tar.bz2
gentoo-3db506579f0478f32a6a3acf8036e0473e801a9f.zip
media-gfx/graphite2: fix build w/ gcc-15
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/graphite2')
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.14-gcc15.patch29
-rw-r--r--media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/graphite2/files/graphite2-1.3.14-gcc15.patch b/media-gfx/graphite2/files/graphite2-1.3.14-gcc15.patch
new file mode 100644
index 000000000000..3eaf56808666
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-1.3.14-gcc15.patch
@@ -0,0 +1,29 @@
+https://github.com/silnrsi/graphite/pull/91
+
+From fb5e7313802a32783cf0a3f1c28880f11e9588a5 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Fri, 2 Aug 2024 22:31:44 +0100
+Subject: [PATCH] tests/featuremap/featuremaptest.cpp: add missing <stdint.h>
+ include
+
+Without the change `graphite` build fails on upcoming `gcc-15` as:
+
+ tests/featuremap/featuremaptest.cpp:30:15: error: 'uint8_t' was not declared in this scope
+ 30 | std::vector<uint8_t> _ttf;
+ | ^~~~~~~
+ tests/featuremap/featuremaptest.cpp:16:1: note: 'uint8_t' is defined in header '<cstdint>';
+ this is probably fixable by adding '#include <cstdint>'
+ 15 | #include "inc/Face.h"
+ +++ |+#include <cstdint>
+ 16 | #include "inc/FeatureMap.h"
+--- a/tests/featuremap/featuremaptest.cpp
++++ b/tests/featuremap/featuremaptest.cpp
+@@ -6,6 +6,7 @@
+ #include <iostream>
+ #include <map>
+ #include <memory>
++#include <stdint.h>
+ #include <string>
+ #include <vector>
+
+
diff --git a/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild b/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild
index 294ba366f782..de205065cc19 100644
--- a/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild
+++ b/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.3.14-fix-nodefaultlibs-deux.patch"
"${FILESDIR}/${PN}-1.3.14-fix-nodefaultlibs.patch"
"${FILESDIR}/${PN}-1.3.5-fix-gcc-linking.patch"
+ "${FILESDIR}/${PN}-1.3.14-gcc15.patch"
)
pkg_setup() {