summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2023-02-14 12:07:12 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-23 12:25:12 +0100
commit14cf2836cf700e656a01d2d09b8c0aed9095262b (patch)
treea54fb0350dca18b5dc00c404e9b59f6d02cc333a /media-gfx/freecad
parentmedia-gfx/freecad: enable netgen support in live ebuild (diff)
downloadgentoo-14cf2836cf700e656a01d2d09b8c0aed9095262b.tar.gz
gentoo-14cf2836cf700e656a01d2d09b8c0aed9095262b.tar.bz2
gentoo-14cf2836cf700e656a01d2d09b8c0aed9095262b.zip
media-gfx/freecad: enable suport for netgen for 0.20.2
Backports from live ebuild - add py3.11 support - better organize dependencies - fix REQUIRED_USE for the designer plugin Closes: https://bugs.gentoo.org/895660 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/29583 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-gfx/freecad')
-rw-r--r--media-gfx/freecad/files/freecad-0.20.2-Fixes-8206-FreeCAD-segfaults-being-run-with-paramete.patch22
-rw-r--r--media-gfx/freecad/files/freecad-0.20.2-Netgen-add-headers-to-support-recent-Netgen.patch93
-rw-r--r--media-gfx/freecad/freecad-0.20.2-r1.ebuild324
3 files changed, 439 insertions, 0 deletions
diff --git a/media-gfx/freecad/files/freecad-0.20.2-Fixes-8206-FreeCAD-segfaults-being-run-with-paramete.patch b/media-gfx/freecad/files/freecad-0.20.2-Fixes-8206-FreeCAD-segfaults-being-run-with-paramete.patch
new file mode 100644
index 000000000000..44d49ca3bf94
--- /dev/null
+++ b/media-gfx/freecad/files/freecad-0.20.2-Fixes-8206-FreeCAD-segfaults-being-run-with-paramete.patch
@@ -0,0 +1,22 @@
+https://github.com/FreeCAD/FreeCAD/commit/c7a21ecbeecefe7c2dfc9e950b3d6bb42351d476
+
+From c7a21ecbeecefe7c2dfc9e950b3d6bb42351d476 Mon Sep 17 00:00:00 2001
+From: wmayer <wmayer@users.sourceforge.net>
+Date: Sat, 11 Feb 2023 17:47:49 +0100
+Subject: [PATCH 02/51] Fixes #8206: FreeCAD segfaults being run with
+ parameters (e.g .desktop file has /usr/bin/freecad --single-instance)
+
+--- a/src/Base/Interpreter.cpp
++++ b/src/Base/Interpreter.cpp
+@@ -563,7 +563,7 @@ void initInterpreter(int argc,char *argv[])
+ {
+ PyStatus status;
+ PyConfig config;
+- PyConfig_InitPythonConfig(&config);
++ PyConfig_InitIsolatedConfig(&config);
+
+ status = PyConfig_SetBytesArgv(&config, argc, argv);
+ if (PyStatus_Exception(status)) {
+--
+2.39.1
+
diff --git a/media-gfx/freecad/files/freecad-0.20.2-Netgen-add-headers-to-support-recent-Netgen.patch b/media-gfx/freecad/files/freecad-0.20.2-Netgen-add-headers-to-support-recent-Netgen.patch
new file mode 100644
index 000000000000..402c84ee4d28
--- /dev/null
+++ b/media-gfx/freecad/files/freecad-0.20.2-Netgen-add-headers-to-support-recent-Netgen.patch
@@ -0,0 +1,93 @@
+https://github.com/FreeCAD/FreeCAD/commit/8b056f156fd087b3df36a5223fc5ca6900649a83
+
+From 8b056f156fd087b3df36a5223fc5ca6900649a83 Mon Sep 17 00:00:00 2001
+From: Uwe <donovaly@users.noreply.github.com>
+Date: Wed, 17 Aug 2022 12:32:02 +0200
+Subject: [PATCH 0008/1678] [Netgen] add headers to support recent Netgen
+
+- as reported here: https://forum.freecadweb.org/viewtopic.php?p=618174#p618174
+- also fix compiler warnings about unsafe bool handling
+--- a/src/3rdParty/salomesmesh/src/NETGENPlugin/NETGENPlugin_Mesher.cpp
++++ b/src/3rdParty/salomesmesh/src/NETGENPlugin/NETGENPlugin_Mesher.cpp
+@@ -50,7 +50,9 @@
+
+ #include <utilities.h>
+
++#include <BRepBndLib.hxx>
+ #include <BRepBuilderAPI_Copy.hxx>
++#include <BRepMesh_IncrementalMesh.hxx>
+ #include <BRep_Tool.hxx>
+ #include <Bnd_B3d.hxx>
+ #include <NCollection_Map.hxx>
+@@ -66,6 +68,7 @@
+ #include <TopTools_DataMapOfShapeShape.hxx>
+ #include <TopTools_MapOfShape.hxx>
+ #include <TopoDS.hxx>
++#include <TopoDS_Solid.hxx>
+
+ #ifdef _MSC_VER
+ #pragma warning(disable : 4067)
+@@ -3027,7 +3030,7 @@ bool NETGENPlugin_Mesher::Compute()
+ }
+ }
+ }
+- if (!err && mparams.secondorder > 0)
++ if (!err && mparams.secondorder)
+ {
+ try
+ {
+@@ -3302,7 +3305,7 @@ bool NETGENPlugin_Mesher::Evaluate(MapShapeNbElems& aResMap)
+ // calculate total nb of segments and length of edges
+ double fullLen = 0.0;
+ int fullNbSeg = 0;
+- int entity = mparams.secondorder > 0 ? SMDSEntity_Quad_Edge : SMDSEntity_Edge;
++ int entity = mparams.secondorder ? SMDSEntity_Quad_Edge : SMDSEntity_Edge;
+ TopTools_DataMapOfShapeInteger Edge2NbSeg;
+ for (TopExp_Explorer exp(_shape, TopAbs_EDGE); exp.More(); exp.Next())
+ {
+@@ -3340,7 +3343,7 @@ bool NETGENPlugin_Mesher::Evaluate(MapShapeNbElems& aResMap)
+ {
+ vector<int>& aVec = aResMap[_mesh->GetSubMesh(Edge2NbSegIt.Key())];
+ if ( aVec[ entity ] > 1 && aVec[ SMDSEntity_Node ] == 0 )
+- aVec[SMDSEntity_Node] = mparams.secondorder > 0 ? 2*aVec[ entity ]-1 : aVec[ entity ]-1;
++ aVec[SMDSEntity_Node] = mparams.secondorder ? 2*aVec[ entity ]-1 : aVec[ entity ]-1;
+
+ fullNbSeg += aVec[ entity ];
+ Edge2NbSeg( Edge2NbSegIt.Key() ) = aVec[ entity ];
+@@ -3386,7 +3389,7 @@ bool NETGENPlugin_Mesher::Evaluate(MapShapeNbElems& aResMap)
+ int nbNodes = tooManyElems ? hugeNb : (( nbFaces*3 - (nb1d-1)*2 ) / 6 + 1 );
+
+ vector<int> aVec(SMDSEntity_Last, 0);
+- if( mparams.secondorder > 0 ) {
++ if (mparams.secondorder) {
+ int nb1d_in = (nbFaces*3 - nb1d) / 2;
+ aVec[SMDSEntity_Node] = nbNodes + nb1d_in;
+ aVec[SMDSEntity_Quad_Triangle] = nbFaces;
+@@ -3428,11 +3431,11 @@ bool NETGENPlugin_Mesher::Evaluate(MapShapeNbElems& aResMap)
+ if ( tooManyElems ) // avoid FPE
+ {
+ aVec[SMDSEntity_Node] = hugeNb;
+- aVec[ mparams.secondorder > 0 ? SMDSEntity_Quad_Tetra : SMDSEntity_Tetra] = hugeNb;
++ aVec[ mparams.secondorder ? SMDSEntity_Quad_Tetra : SMDSEntity_Tetra] = hugeNb;
+ }
+ else
+ {
+- if( mparams.secondorder > 0 ) {
++ if (mparams.secondorder) {
+ aVec[SMDSEntity_Node] = nb1d_in/3 + 1 + nb1d_in;
+ aVec[SMDSEntity_Quad_Tetra] = nbVols;
+ }
+--- a/src/3rdParty/salomesmesh/src/NETGENPlugin/NETGENPlugin_NETGEN_2D_ONLY.cpp
++++ b/src/3rdParty/salomesmesh/src/NETGENPlugin/NETGENPlugin_NETGEN_2D_ONLY.cpp
+@@ -39,6 +39,8 @@
+ #include <StdMeshers_MaxElementArea.hxx>
+ #include <StdMeshers_QuadranglePreference.hxx>
+ #include <StdMeshers_ViscousLayers2D.hxx>
++#include <TopExp.hxx>
++#include <TopExp_Explorer.hxx>
+
+ #include <Precision.hxx>
+ #include <Standard_ErrorHandler.hxx>
+--
+2.39.1
+
diff --git a/media-gfx/freecad/freecad-0.20.2-r1.ebuild b/media-gfx/freecad/freecad-0.20.2-r1.ebuild
new file mode 100644
index 000000000000..4099ed239e45
--- /dev/null
+++ b/media-gfx/freecad/freecad-0.20.2-r1.ebuild
@@ -0,0 +1,324 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit check-reqs cmake optfeature python-single-r1 xdg
+
+DESCRIPTION="QT based Computer Aided Design application"
+HOMEPAGE="https://www.freecad.org/ https://github.com/FreeCAD/FreeCAD"
+
+MY_PN=FreeCAD
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ S="${WORKDIR}/freecad-${PV}"
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/FreeCAD-${PV}"
+fi
+
+# code is licensed LGPL-2
+# examples are licensed CC-BY-SA (without note of specific version)
+LICENSE="LGPL-2 CC-BY-SA-4.0"
+SLOT="0"
+IUSE="debug designer +gui test"
+
+FREECAD_EXPERIMENTAL_MODULES="cloud netgen pcl"
+FREECAD_STABLE_MODULES="addonmgr fem idf image inspection material
+ openscad part-design path points raytracing robot show surface
+ techdraw tux"
+
+for module in ${FREECAD_STABLE_MODULES}; do
+ IUSE="${IUSE} +${module}"
+done
+for module in ${FREECAD_EXPERIMENTAL_MODULES}; do
+ IUSE="${IUSE} ${module}"
+done
+unset module
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/OpenNI2[opengl(+)]
+ dev-libs/boost:=
+ dev-libs/libspnav[X]
+ dev-libs/xerces-c[icu]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ dev-qt/qtxmlpatterns:5
+ media-libs/freetype
+ media-libs/qhull:=
+ sci-libs/flann[openmp]
+ sci-libs/hdf5:=[fortran,zlib]
+ >=sci-libs/med-4.0.0-r1
+ <sci-libs/opencascade-7.7.0:=[json,vtk]
+ sci-libs/orocos_kdl:=
+ sys-libs/zlib
+ virtual/libusb:1
+ cloud? (
+ dev-libs/openssl:=
+ net-misc/curl
+ )
+ fem? ( sci-libs/vtk:=[qt5,rendering] )
+ gui? (
+ dev-qt/designer:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=media-libs/coin-4.0.0
+ virtual/glu
+ virtual/opengl
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/pivy-0.6.5[${PYTHON_USEDEP}]
+ dev-python/pyside2[gui,svg,webchannel,webengine,${PYTHON_USEDEP}]
+ dev-python/shiboken2[${PYTHON_USEDEP}]
+ ')
+ )
+ netgen? ( media-gfx/netgen[opencascade] )
+ openscad? ( media-gfx/openscad )
+ pcl? ( sci-libs/pcl:=[opengl,openni2,qt5,vtk] )
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ addonmgr? ( dev-python/GitPython[${PYTHON_USEDEP}] )
+ fem? ( dev-python/ply[${PYTHON_USEDEP}] )
+ ')
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-cpp/eigen-3.3.1:3
+ test? (
+ $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
+ dev-qt/qttest:5
+ )
+"
+BDEPEND="
+ app-text/dos2unix
+ dev-lang/swig
+ test? (
+ $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
+ dev-qt/qttest:5
+ )
+"
+
+# To get required dependencies:
+# 'grep REQUIRES_MODS cMake/FreeCAD_Helpers/CheckInterModuleDependencies.cmake'
+# We set the following requirements by default:
+# arch, draft, drawing, import, mesh, part, qt5, sketcher, spreadsheet, start, web.
+#
+# Additionally, we auto-enable mesh_part, flat_mesh and smesh
+# Fem actually needs smesh, but as long as we don't have a smesh package, we enable
+# smesh through the mesh USE flag. Note however, the fem<-smesh dependency isn't
+# reflected by the REQUIRES_MODS macro, but at
+# cMake/FreeCAD_Helpers/InitializeFreeCADBuildOptions.cmake:187.
+#
+# The increase in auto-enabled workbenches is due to their need in parts of the
+# test suite when compiled with a minimal set of USE flags.
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ designer? ( gui )
+ inspection? ( points )
+ path? ( robot )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.19.4-Gentoo-specific-don-t-check-vcs.patch
+ "${FILESDIR}"/${PN}-0.19.1-0001-Gentoo-specific-Remove-ccache-usage.patch
+ "${FILESDIR}"/${PN}-0.20.2-Netgen-add-headers-to-support-recent-Netgen.patch
+ "${FILESDIR}"/${PN}-0.20.2-Fixes-8206-FreeCAD-segfaults-being-run-with-paramete.patch
+)
+
+DOCS=( CODE_OF_CONDUCT.md ChangeLog.txt README.md )
+
+CHECKREQS_DISK_BUILD="2G"
+
+pkg_setup() {
+ check-reqs_pkg_setup
+ python-single-r1_pkg_setup
+ [[ -z ${CASROOT} ]] && die "\${CASROOT} not set, please run eselect opencascade"
+}
+
+src_prepare() {
+ # Fix desktop file
+ sed -e 's/Exec=FreeCAD/Exec=freecad/' -i src/XDGData/org.freecadweb.FreeCAD.desktop || die
+
+ find "${S}" -type f -exec dos2unix -q {} \; || die "failed to convert to unix line endings"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_ADDONMGR=$(usex addonmgr)
+ -DBUILD_ARCH=ON
+ -DBUILD_ASSEMBLY=OFF # deprecated
+ -DBUILD_CLOUD=$(usex cloud)
+ -DBUILD_COMPLETE=OFF # deprecated
+ -DBUILD_DRAFT=ON
+ -DBUILD_DESIGNER_PLUGIN=$(usex designer)
+ -DBUILD_DRAWING=ON
+ -DBUILD_ENABLE_CXX_STD:STRING="C++17" # needed for >=boost-1.77.0
+ -DBUILD_FEM=$(usex fem)
+ -DBUILD_FEM_NETGEN=$(usex netgen)
+ -DBUILD_FLAT_MESH=ON
+ -DBUILD_FORCE_DIRECTORY=ON # force building in a dedicated directory
+ -DBUILD_FREETYPE=ON # automagic dep
+ -DBUILD_GUI=$(usex gui)
+ -DBUILD_IDF=$(usex idf)
+ -DBUILD_IMAGE=$(usex image)
+ -DBUILD_IMPORT=ON # import module for various file formats
+ -DBUILD_INSPECTION=$(usex inspection)
+ -DBUILD_JTREADER=OFF # code has been removed upstream, but option is still there
+ -DBUILD_MATERIAL=$(usex material)
+ -DBUILD_MESH=ON
+ -DBUILD_MESH_PART=ON
+ -DBUILD_OPENSCAD=$(usex openscad)
+ -DBUILD_PART=ON
+ -DBUILD_PART_DESIGN=$(usex part-design)
+ -DBUILD_PATH=$(usex path)
+ -DBUILD_POINTS=$(usex points)
+ -DBUILD_QT5=ON # OFF means to use Qt4
+ -DBUILD_RAYTRACING=$(usex raytracing)
+ -DBUILD_REVERSEENGINEERING=OFF # currently only an empty sandbox
+ -DBUILD_ROBOT=$(usex robot)
+ -DBUILD_SHOW=$(usex show)
+ -DBUILD_SKETCHER=ON # needed by draft workspace
+ -DBUILD_SMESH=ON
+ -DBUILD_SPREADSHEET=ON
+ -DBUILD_START=ON
+ -DBUILD_SURFACE=$(usex surface)
+ -DBUILD_TECHDRAW=$(usex techdraw)
+ -DBUILD_TEST=ON # always build test workbench for run-time testing
+ -DBUILD_TUX=$(usex tux)
+ -DBUILD_VR=OFF
+ -DBUILD_WEB=ON # needed by start workspace
+ -DBUILD_WITH_CONDA=OFF
+
+ -DCMAKE_INSTALL_DATADIR=/usr/share/${PN}/data
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DCMAKE_INSTALL_INCLUDEDIR=/usr/include/${PN}
+ -DCMAKE_INSTALL_PREFIX=/usr/$(get_libdir)/${PN}
+
+ -DFREECAD_BUILD_DEBIAN=OFF
+
+ -DFREECAD_QT_VERSION="5"
+
+ -DFREECAD_USE_EXTERNAL_KDL=ON
+ -DFREECAD_USE_EXTERNAL_SMESH=OFF # no package in Gentoo
+ -DFREECAD_USE_EXTERNAL_ZIPIOS=OFF # doesn't work yet, also no package in Gentoo tree
+ -DFREECAD_USE_FREETYPE=ON
+ -DFREECAD_USE_OCC_VARIANT:STRING="Official Version"
+ -DFREECAD_USE_PCL=$(usex pcl)
+ -DFREECAD_USE_PYBIND11=ON
+ -DFREECAD_USE_QT_FILEDIALOG=ON
+ -DFREECAD_USE_QTWEBMODULE:STRING="Qt WebEngine"
+
+ # install python modules to site-packages' dir. True only for the main package,
+ # sub-packages will still be installed inside /usr/lib64/freecad
+ -DINSTALL_TO_SITEPACKAGES=ON
+
+ # Use the version of shiboken2 that matches the selected python version
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+ -DPython3_EXECUTABLE=${PYTHON}
+ )
+
+ if use debug; then
+ # BUILD_SANDBOX currently broken, see
+ # https://forum.freecadweb.org/viewtopic.php?f=4&t=36071&start=30#p504595
+ mycmakeargs+=(
+ -DBUILD_SANDBOX=OFF
+ -DBUILD_TEMPLATE=ON
+ )
+ else
+ mycmakeargs+=(
+ -DBUILD_SANDBOX=OFF
+ -DBUILD_TEMPLATE=OFF
+ )
+ fi
+
+ cmake_src_configure
+}
+
+# We use the FreeCADCmd binary instead of the FreeCAD binary here
+# for two reasons:
+# 1. It works out of the box with USE=-gui as well, not needing a guard
+# 2. We don't need virtualx.eclass and it's dependencies
+# The exported environment variables are needed, so freecad does know
+# where to save it's temporary files, and where to look and write it's
+# configuration. Without those, there are sandbox violation, when it
+# tries to create /var/lib/portage/home/.FreeCAD directory.
+src_test() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ export FREECAD_USER_HOME="${HOME}"
+ export FREECAD_USER_DATA="${T}"
+ export FREECAD_USER_TEMP="${T}"
+ nonfatal ./bin/FreeCADCmd --run-test 0
+ popd > /dev/null || die
+}
+
+src_install() {
+ cmake_src_install
+
+ dobin src/Tools/freecad-thumbnailer
+
+ if use gui; then
+ dosym -r /usr/$(get_libdir)/${PN}/bin/FreeCAD /usr/bin/freecad
+ mv "${ED}"/usr/$(get_libdir)/${PN}/share/* "${ED}"/usr/share || die "failed to move shared resources"
+ fi
+ dosym -r /usr/$(get_libdir)/${PN}/bin/FreeCADCmd /usr/bin/freecadcmd
+
+ rm -r "${ED}"/usr/$(get_libdir)/${PN}/include/E57Format || die "failed to drop unneeded include directory E57Format"
+
+ python_optimize "${ED}"/usr/share/${PN}/data/Mod/Start/StartPage "${ED}"/usr/$(get_libdir)/${PN}{/Ext,/Mod}/
+ # compile main package in python site-packages as well
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ einfo "You can load a lot of additional workbenches using the integrated"
+ einfo "AddonManager."
+
+ # ToDo: check opencv, pysolar (::science), elmerfem (::science)
+ # ifc++, ifcopenshell, z88 (no pkgs), calculix-ccx (::waebbl)
+ einfo "There are a lot of additional tools, for which FreeCAD has builtin"
+ einfo "support. Some of them are available in Gentoo. Take a look at"
+ einfo "https://wiki.freecadweb.org/Installing#External_software_supported_by_FreeCAD"
+ optfeature_header "Computational utilities"
+ optfeature "BLAS library" sci-libs/openblas
+ optfeature "Statistical computation with Python" dev-python/pandas
+ optfeature "Use scientific computation with Python" dev-python/scipy
+ optfeature "Use symbolic math with Python" dev-python/sympy
+ optfeature_header "Imaging, Plotting and Rendering utilities"
+ optfeature "Dependency graphs" media-gfx/graphviz
+ optfeature "PBR Rendering" media-gfx/povray
+ optfeature_header "Import / Export"
+ optfeature "Interact with git repositories" dev-python/GitPython
+ optfeature "Work with COLLADA documents" dev-python/pycollada
+ optfeature "YAML importer and emitter" dev-python/pyyaml
+ optfeature "Importing and exporting 2D AutoCAD DWG files" media-gfx/libredwg
+ optfeature "Importing and exporting geospatial data formats" sci-libs/gdal
+ optfeature "Working with projection data" sci-libs/proj
+ optfeature_header "Meshing and FEM"
+ optfeature "FEM mesh generator" sci-libs/gmsh
+ optfeature "Triangulating meshes" sci-libs/gts
+ optfeature "Visualization" sci-visualization/paraview
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}