summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2025-02-10 10:23:13 -0500
committerCraig Andrews <candrews@gentoo.org>2025-02-10 10:24:11 -0500
commit8669f614c6d56f92743ff8c85ea6d5314f63b7e8 (patch)
tree8afcbf2e9f9751ef5bebe36956c0dc2851e1f6e2 /mail-client/roundcube
parentwww-apps/radarr-bin: drop 5.18.4.9674 (diff)
downloadgentoo-8669f614c6d56f92743ff8c85ea6d5314f63b7e8.tar.gz
gentoo-8669f614c6d56f92743ff8c85ea6d5314f63b7e8.tar.bz2
gentoo-8669f614c6d56f92743ff8c85ea6d5314f63b7e8.zip
mail-client/roundcube: add 1.6.10
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.6.10.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 161a62697d6f..8a03ccf28fbe 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,2 +1,3 @@
+DIST roundcubemail-1.6.10-complete.tar.gz 5839015 BLAKE2B cdf826e42b7cbc19ee5d8eb0d2584527182223b05f2dcfc35cd947752aec8699df74406b18e7f704e09eb7091e1591e736c76e9db08340c6f4ef583e0bb8663a SHA512 e9d8d3cf8c0a751a8b33558de04238f1f831d23ceaf090802a34b826a5aeb49e2ca6235c90250d903da7e0f636fcf2e687205f2ab14427e423ed3408966f4c54
DIST roundcubemail-1.6.7-complete.tar.gz 5899345 BLAKE2B c22803f3651c32f863081afe28d05e4b7918ba0cb1238c11de646a0fe3a16a6faff633a3a193a5813a50be710a71a8900d049f0e628661b6c7c036c0d69055ab SHA512 aedc940e769e881d448eced2ef0b603c87f9a9e18624cae4d14a946e6f9509c827f75e6fb294a760970e37caa9ab0bfb0a7ec8843b12542f59f350948d2d8d3b
DIST roundcubemail-1.6.9-complete.tar.gz 5899444 BLAKE2B dc7409bec9c4bdfca4d55e2ebc2a1f688e7ce48bc1425ae99cba55b7340732e256f55c58fd4427ff7d932875ba9185f0bf6774760c3c800e3991ecbdb0eb8723 SHA512 b5f3f55da9cd75e550cba50d0980e1b1b6911a4ded02520fbd5d2f4ea9d30b695f9f1f2a66536fe7ba820e9337dd9c2f51132c5db622e853adb29a84118edec9
diff --git a/mail-client/roundcube/roundcube-1.6.10.ebuild b/mail-client/roundcube/roundcube-1.6.10.ebuild
new file mode 100644
index 000000000000..b8ed617003f8
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.6.10.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-7.4.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ rm Makefile || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}