summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2025-01-30 19:12:52 +0200
committerJimi Huotari <chiitoo@gentoo.org>2025-01-30 19:12:52 +0200
commit4fa0375633285d65d904814462b3909756d7978e (patch)
tree2046bfd26e706acdc5a5e5b615ce32ab90e4c110 /lxqt-base
parentmedia-gfx/lximage-qt: add 2.1.1 (diff)
downloadgentoo-4fa0375633285d65d904814462b3909756d7978e.tar.gz
gentoo-4fa0375633285d65d904814462b3909756d7978e.tar.bz2
gentoo-4fa0375633285d65d904814462b3909756d7978e.zip
lxqt-base/lxqt-runner: add 2.1.2
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-runner/Manifest1
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-2.1.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/Manifest b/lxqt-base/lxqt-runner/Manifest
index b8284194e683..f2fde7084ecd 100644
--- a/lxqt-base/lxqt-runner/Manifest
+++ b/lxqt-base/lxqt-runner/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-runner-2.0.0.tar.xz 226344 BLAKE2B 3b831d1d1b0226e1785d4ee4fc93055cf01426335001c432cfc099f75c14421f467fa761648e77d826dfd6b36c9867779b88e38d971fe78846b102bcb7c945d1 SHA512 4c9ff79a0a4b7167023bd5447c83692be2e4e79ae48b6069deadae8ab4e5d6d73e6439169ffce87fc8f6000e65ed354fffb58188e9ba4f762b177b1c85c284c5
DIST lxqt-runner-2.1.1.tar.xz 227132 BLAKE2B a605012e8e4da84e527138345cfade620c6b67da52d82d4b1b37f1afcc987f400ef6ccc4f74c7909700befd4c3c6e8b28f7355bf5fb90ca149712606fbf0ccea SHA512 902a4934dfdb926e27562a333c97c5786828e487a6eed326bbf59435ea873936af92e39c0477f131541a2591a13ecd9f750adac0bb3a437283fc377ce463313a
+DIST lxqt-runner-2.1.2.tar.xz 227172 BLAKE2B b57598295cbc061ac64a06f215ded69614952caeae5f00aa5e6d8542a3d7d6072b6739a46c2f7e0de5df7a3567eac5f46c1381fc3829c7d8b54cafeca654b952 SHA512 bc08daeae6df531a272d5ebeff5f2cde826336fd3784bc2d0f2fa49ccc24c1af28971e08db78e0cb36619dd236f8fee7cf0a0fc51b1f469e331ade9d146dbb97
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-2.1.2.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-2.1.2.ebuild
new file mode 100644
index 000000000000..1cd6924ca364
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-2.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.1.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/muParser-2.2.3
+ >=dev-libs/libqtxdg-4.1.0
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets,xml]
+ kde-frameworks/kwindowsystem:6
+ >=kde-plasma/layer-shell-qt-6.0:6
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ =lxqt-base/lxqt-globalkeys-${MY_PV}*
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}