summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-26 18:32:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-26 19:24:27 +0100
commit72408739a285f6c491efa7034174b5b72d90718b (patch)
tree878cdc19f235144829ad25e9a177853af63fc8c6 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 6.2.4 version bump (diff)
downloadgentoo-72408739a285f6c491efa7034174b5b72d90718b.tar.gz
gentoo-72408739a285f6c491efa7034174b5b72d90718b.tar.bz2
gentoo-72408739a285f6c491efa7034174b5b72d90718b.zip
kde-plasma/kwallet-pam: 6.2.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.2.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 82498cd256f3..a807fd158663 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-6.1.5.tar.xz 22524 BLAKE2B 3ae0ed78f568962ba24261d7f0801e9405c6356d4688ec914da750663cc10d2a0ada0b58dda4c5aa50035bda3f71b094654596ed5a00af91e433bb968854b4ad SHA512 367836153d8624c9e1df9fa24a05d09455d36584bceb452bb27958eeabc6a71648fa8cff77d3674e8cc21cf30044da2427a81d7302acb4e512de2c8d8b34258a
DIST kwallet-pam-6.2.3.tar.xz 22464 BLAKE2B d2afe85983739f37cbb1d4672b863b129f52521f7ba68b29e741d128734ef8feb53bcb02135382e6ce5a4780663889a9e9d3e0f6a0012f6097b3b036aae7f5ee SHA512 217d4935e305c7970d65f79d7fa60f4f4a94612b0061b52eccb1d1e430eb5084135ae2ab00bcc8741c9d7c0da2f61d3e4fcb3d1e054c5c57336bd6a2ff6973af
+DIST kwallet-pam-6.2.4.tar.xz 22464 BLAKE2B 3ee714b89df04539a2e0b60d151daf66403d66f8cb7a71aa401c00bf72831acadac0f1d5a3a5d9999903ae8bc4fc7b45468a842fd9b1dedc0c2b09cfa912efb8 SHA512 cf6210ff1cb9946149936e1cafd890cfbca23e8cce8beab8fc057d996bb8b896cad9415046c7a2bd8600eba675b20aea78c3de87da74a1bfe8587c2b60fa3c03
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.2.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.2.4.ebuild
new file mode 100644
index 000000000000..dfa8a66a00e8
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}