summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-27 18:59:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-28 00:23:04 +0200
commite6567a60b1c29fe72191478298ceb799f96a8cf6 (patch)
treea0b3525e94fe4807955d80fd7dfb7181e06e3bd5 /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 6.0.90 version bump (diff)
downloadgentoo-e6567a60b1c29fe72191478298ceb799f96a8cf6.tar.gz
gentoo-e6567a60b1c29fe72191478298ceb799f96a8cf6.tar.bz2
gentoo-e6567a60b1c29fe72191478298ceb799f96a8cf6.zip
kde-plasma/ksshaskpass: 6.0.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.0.90.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index a42d1b979af4..5d76c57ad716 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.11.tar.xz 27980 BLAKE2B 4fa35480f0ed7389bf41f56fc8266fccb8a33060c37f6df2c1edc44f49466267dbd45584e0afff6aaa79a3b5ffc1aca916c36a7ad768e36a457c081bfa53f217 SHA512 85c4091faa4ec4a6d068d4a0d464601054b88187ccfa05f4156b146dd3b3900dc15bcb3f9f9b0b057fb9b5687eabf55bb34d06d98a9e26ddb6a0afba1684feee
DIST ksshaskpass-6.0.5.tar.xz 28880 BLAKE2B 40e623de164f9f9bd4c1571c49af48b6825901eb35930272826f73334c0a0b675c11abb6b27fc81e1719808f1e473145e41955f395c82925792ca2dd2ddf1045 SHA512 78501f93534a95fc03005ce1e84a0ebb67ffacd6c16af84b18ed0fd1a98ec72783423c66fb79ae788ecd2ce1e1b68a401fc62b2c202f042ce5603e7ce712b641
+DIST ksshaskpass-6.0.90.tar.xz 29428 BLAKE2B 0498dd75e2e1bfc3f4b09aefa579d7744a138e72bd8c45905686ef16ee7656975f6f68200adc4ecae311c4596a53e7ce8ebe1108b2fd730a4a7e5a623e8a0048 SHA512 5a92080d11b9fc404a6f65defe7a23c01ecdd70b7903885b3f746c2bee2dbe289a5d01e024d26bd44b5aa20906a7e7fb3ea0b5f22dbe295716b0468e33d4fc7b
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.0.90.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.0.90.ebuild
new file mode 100644
index 000000000000..0a145c060723
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.0.90.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.2.0
+QTMIN=6.7.1
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}