summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 19:35:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 20:02:07 +0100
commit5ef54f77e2ace64a93bc86711dbf3f49052f8a08 (patch)
tree6e8972ea0258a82d4f54a61ec0f856b8dd992781 /kde-plasma/kinfocenter
parentkde-plasma/kglobalacceld: 6.2.3 version bump (diff)
downloadgentoo-5ef54f77e2ace64a93bc86711dbf3f49052f8a08.tar.gz
gentoo-5ef54f77e2ace64a93bc86711dbf3f49052f8a08.tar.bz2
gentoo-5ef54f77e2ace64a93bc86711dbf3f49052f8a08.zip
kde-plasma/kinfocenter: 6.2.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.2.3.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index efc4f99e3a46..e3bcae0b1283 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-6.1.5.tar.xz 720016 BLAKE2B e0555f40fcf6ab5aac032b9366322b05cb38f60288ee275b2e69bf7116f80c6ca922b6dbacbb417aaffa66157d9f9216defad07de9705f03f7cec5f4c5145f64 SHA512 58909d0804d23bb17961ba471e8f3db8cd58e66c6df4bc4ac27eecaa99e003351df08f9b099589c78160459e4147d461f15b5d4df8140ef40778020445da9085
DIST kinfocenter-6.2.2.tar.xz 731244 BLAKE2B afb41154733552d456c560f5f583a302e5d538969650c38d2f9b4fc79dd1c3242cbd83616fdc9c6cb070aa432ca4f732a4a4a5b3fecf147e28170e5f79f2c618 SHA512 81c02acb31f70ee06296b3bda7054d535285fd64b7ff07c2fff02d38c3acbf2056fd3a62c23c45bdc7c03087c1ed518b9e6ef8b7d1fc56b45d037b70435a4f62
+DIST kinfocenter-6.2.3.tar.xz 731288 BLAKE2B a55d589ac0dfb9b115043ebd05446c2c820023d4860c1d1580ecdb2ed5edceac75ac79f78d2a0e02e931eedcba743a832031e0fc894281678728b46f3fa4b474 SHA512 137720c390f39b4722db3ed3c79bd6c782f90eb389b0342f870e506832204bba8b1ab2415baec6314d28037c7e6f4ecf7dae0c6ff20a9eec6b40bc11975990c9
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.2.3.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.2.3.ebuild
new file mode 100644
index 000000000000..d96e193835ba
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-6.2.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=6.6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.2
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gles2-only=,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ gles2-only? ( || (
+ >=media-libs/mesa-24.1.0_rc1[opengl]
+ <media-libs/mesa-24.1.0_rc1[gles2]
+ ) )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ || (
+ >=dev-qt/qttools-${QTMIN}:6[qdbus]
+ dev-qt/qdbus:*
+ )
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-plasma/systemsettings-${PVCUT}:6
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+CMAKE_SKIP_TESTS=(
+ # bug 816591
+ smbmountmodeltest
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ -DCMAKE_DISABLE_FIND_PACKAGE_SeleniumWebDriverATSPI=ON # missing
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature_header "Query network filesystem info:"
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature_header "Query firmware/hardware info:"
+ fi
+ optfeature "System DMI table readout" sys-apps/dmidecode
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ optfeature_header "Query GPU/graphics support info:"
+ fi
+ optfeature "OpenCL information module" dev-util/clinfo
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ fi
+ ecm_pkg_postinst
+}