summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-03 18:52:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-03 21:35:50 +0100
commite0c891ae42b7435d318550f33310ae70fe7e2a10 (patch)
treea4ac866ffc92dd90f89b78903431773bcc8898c5 /kde-frameworks
parentmedia-sound/drumstick: drop 2.6.1-r1 (diff)
downloadgentoo-e0c891ae42b7435d318550f33310ae70fe7e2a10.tar.gz
gentoo-e0c891ae42b7435d318550f33310ae70fe7e2a10.tar.bz2
gentoo-e0c891ae42b7435d318550f33310ae70fe7e2a10.zip
kde-frameworks/kwallet: Don't exclude deprecated functions from build
KDE-bug: https://bugs.kde.org/show_bug.cgi?id=493356 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kwallet/files/kwallet-6.7.0-no-exclude-deprecated.patch34
-rw-r--r--kde-frameworks/kwallet/kwallet-6.7.0-r1.ebuild55
2 files changed, 89 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/files/kwallet-6.7.0-no-exclude-deprecated.patch b/kde-frameworks/kwallet/files/kwallet-6.7.0-no-exclude-deprecated.patch
new file mode 100644
index 000000000000..0c8c00629d20
--- /dev/null
+++ b/kde-frameworks/kwallet/files/kwallet-6.7.0-no-exclude-deprecated.patch
@@ -0,0 +1,34 @@
+From 38f293ce0b025ad30d7bc1fd5c0f8dd1d3b07c6c Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Fri, 18 Oct 2024 23:15:19 +0200
+Subject: [PATCH] Don't exclude deprecated functions from build
+
+Some of the deprecated API is part of the runtime DBus interface and might be used by older applications
+
+BUG: 493356
+---
+ CMakeLists.txt | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c31f8e12..8cffe41e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,11 +33,10 @@ option(BUILD_KWALLET_QUERY "Build kwallet-query tool" ON)
+ option(BUILD_QCH "Build API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)" OFF)
+ add_feature_info(QCH ${BUILD_QCH} "API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)")
+
+-if (TRUE) # TODO: port and remove remaining code in v5-time deprecated parts, then return to using 0
+-set(EXCLUDE_DEPRECATED_BEFORE_AND_AT 5.99.0 CACHE STRING "Control the range of deprecated API excluded from the build [default=5.99.0].")
+-else() # normal
++# kwalletd contains functions that are marked as deprecated.
++# These are part of the public DBus API and are used by older applications
++# Therefore we must not exclude those by default
+ set(EXCLUDE_DEPRECATED_BEFORE_AND_AT 0 CACHE STRING "Control the range of deprecated API excluded from the build [default=0].")
+-endif()
+
+ find_package(KF6CoreAddons ${KF_DEP_VERSION} REQUIRED)
+ find_package(KF6Config ${KF_DEP_VERSION} REQUIRED)
+--
+GitLab
+
diff --git a/kde-frameworks/kwallet/kwallet-6.7.0-r1.ebuild b/kde-frameworks/kwallet/kwallet-6.7.0-r1.ebuild
new file mode 100644
index 000000000000..9ff9a2b669ef
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-6.7.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gpg +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt6(-)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/kcrash-${PVCUT}*:6
+ =kde-frameworks/kdbusaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+ =kde-frameworks/kwindowsystem-${PVCUT}*:6[X]
+ gpg? ( app-crypt/gpgme:=[qt6(-)] )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:6 )"
+
+PATCHES=( "${FILESDIR}/${P}-no-exclude-deprecated.patch" ) # KDE-bug 493356
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF6DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after Plasma login" "kde-plasma/kwallet-pam"
+ optfeature "KWallet management" "kde-apps/kwalletmanager"
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}