summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 18:32:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 19:07:34 +0200
commitab73efea46f22f577e055646d64ddc3d44e0968c (patch)
tree095a614b9bea4f8285e56a396495e6eab3288d8e /kde-frameworks/sonnet
parentkde-frameworks/solid: 5.85.0 version bump (diff)
downloadgentoo-ab73efea46f22f577e055646d64ddc3d44e0968c.tar.gz
gentoo-ab73efea46f22f577e055646d64ddc3d44e0968c.tar.bz2
gentoo-ab73efea46f22f577e055646d64ddc3d44e0968c.zip
kde-frameworks/sonnet: 5.85.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.85.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 28959ba4b308..19b1ae53d6a8 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.82.0.tar.xz 293844 BLAKE2B 6e2c4558957d845a281955c63de7dd87fc21634a4cb3e89af47345da070b1dc15e91c558a865e0c7ac5e2adb2454d36b6b8f2f521112b4fd07ad1b2ad02f6c04 SHA512 3bc876b1e06ba5c08c05ce74530a2584b9853e8c9742f66b19529e7f78f3aad89d3a72e0a615e912d1cfd7a24b3de3a9068d0f72dce3c51ca03b896eeedde817
DIST sonnet-5.84.0.tar.xz 295300 BLAKE2B bafd06d4b57841c4fa39e55235f12dbe447316f4e2af3b1b2dde3f9f6eb817a97a2298320447fbc0a2186ba50e5cd6bd62e77a5828087b65b6097961babaa7af SHA512 49021de3684d899b20b2ba8f980a701e3f467b0a9f76935fc38c347881a371bb0c51f924d44fc819f86119589df1391427365aabd92c1eebbd66f8d46bdf901d
+DIST sonnet-5.85.0.tar.xz 297068 BLAKE2B 7f5bad0ebe851443dd2150be3784442008ffd7ad7acdacb42d0f3495490477a1f570a0aec6dd1b600ca01a5f9fa13c87f56cceb50c98cc2ab399ce85bc04c369 SHA512 50ed8787a8c7378574376ef0539b211eafb349f139fabe6d22788af91d57e758c994ddfdf72d83d76009570dbc8dd4bcb3df3add5c9dc17347b9263e09969930
diff --git a/kde-frameworks/sonnet/sonnet-5.85.0.ebuild b/kde-frameworks/sonnet/sonnet-5.85.0.ebuild
new file mode 100644
index 000000000000..c2df24e9d697
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.85.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # sonnet-test_settings: bug 680032
+ # sonnet-test_autodetect: bug 779994
+ local myctestargs=(
+ -E "(sonnet-test_autodetect|sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}