summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-12-10 20:44:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-12-12 23:12:03 +0100
commit9d62a3b47c7e4febd79dfb2c2a16d1b02a05639e (patch)
tree42084092a126e74b851ff25773f10912349e42a8 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.89.0 version bump (diff)
downloadgentoo-9d62a3b47c7e4febd79dfb2c2a16d1b02a05639e.tar.gz
gentoo-9d62a3b47c7e4febd79dfb2c2a16d1b02a05639e.tar.bz2
gentoo-9d62a3b47c7e4febd79dfb2c2a16d1b02a05639e.zip
kde-frameworks/purpose: 5.89.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.89.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 8893e670cd1b..952feda5c2b6 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.85.0.tar.xz 161412 BLAKE2B c6d55396ebde4f8b3f08a71c429bce4f0bbfe1303907d06faf841ab53147a78b582bd63e4b731eb6c5d16b939dade6dab2ca30930a9fa31babb9c1b68c37e53e SHA512 30da8286d7eb8b0652656d0c52fe0f95dd4c3c1f86e468af5f9b546b0afc996dbf9f3a0e011376de5b58e34bf529faca9f3add7ee0e820ab693745c98e21b1ed
DIST purpose-5.88.0.tar.xz 165852 BLAKE2B 67603932b1d092eda49e4011dd2ebf8feb6862e315dc8cc3ce12a14f26e3796bd05f39e1ee91a119629b3cf2c962c3e44c600b4200e9c1fe0ecaf96ba8476673 SHA512 b21e5f50fe463f58cb3be92039e45c4c88f775d6612f85f9711090926ae65798ed159b825196fa314191fbb08eb52ae4d35077b48a1b4d6987291c6380893fae
+DIST purpose-5.89.0.tar.xz 168224 BLAKE2B 69b86d0c3e4fde7e11907286151532e87046d446457a89ea5f8d40f69d00b6c8583bab014d26b94ed6187a663dca8aa319930708cec57d92048ae156c03c2a0f SHA512 a3552c54f4c2e7084168a266b812f9d7a2697ade4b3f3f25eba868c7143fe2eeb25b5c1d0504e65a0677b7dbbf75b544450175c1d9ba04deb78a5132b90a5893
diff --git a/kde-frameworks/purpose/purpose-5.89.0.ebuild b/kde-frameworks/purpose/purpose-5.89.0.ebuild
new file mode 100644
index 000000000000..8f61c83816a7
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.89.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}