summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 21:01:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 21:24:48 +0200
commite9bcf38cf8d071bb18aa74bd9fee1ddb6f8b0698 (patch)
treef171b5ab7ea8ec7bcc77c33648cacd859d332665 /kde-frameworks/kpackage/kpackage-5.116.0.ebuild
parentkde-frameworks/knotifications: 5.116.0 version bump (diff)
downloadgentoo-e9bcf38cf8d071bb18aa74bd9fee1ddb6f8b0698.tar.gz
gentoo-e9bcf38cf8d071bb18aa74bd9fee1ddb6f8b0698.tar.bz2
gentoo-e9bcf38cf8d071bb18aa74bd9fee1ddb6f8b0698.zip
kde-frameworks/kpackage: 5.116.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpackage/kpackage-5.116.0.ebuild')
-rw-r--r--kde-frameworks/kpackage/kpackage-5.116.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kpackage/kpackage-5.116.0.ebuild b/kde-frameworks/kpackage/kpackage-5.116.0.ebuild
new file mode 100644
index 000000000000..d2c17b177f26
--- /dev/null
+++ b/kde-frameworks/kpackage/kpackage-5.116.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to install and load packages of non binary content"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # bug 650214
+ plasma-plasmoidpackagetest
+ # requires network access
+ testpackage-appstream
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}