summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-03-05 20:12:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 23:14:20 +0100
commit0529597c04d9e2293c1ee5fdc5744f47717f2979 (patch)
treea603beb882105d2dfdcd177db680a388e59ced1d /kde-apps/libkleo
parentsci-calculators/units: Fix shebang, convert to python-single-r1 (diff)
downloadgentoo-0529597c04d9e2293c1ee5fdc5744f47717f2979.tar.gz
gentoo-0529597c04d9e2293c1ee5fdc5744f47717f2979.tar.bz2
gentoo-0529597c04d9e2293c1ee5fdc5744f47717f2979.zip
kde-apps/libkleo: Install headers for kde-apps/kopete[cryptography]
Patch backported from kde-apps/kdepim-common-libs/files/kdepim-common-libs-install-headers.patch
Diffstat (limited to 'kde-apps/libkleo')
-rw-r--r--kde-apps/libkleo/files/libkleo-4.4.2016.01-install_headers.patch69
-rw-r--r--kde-apps/libkleo/libkleo-4.4.2016.01-r1.ebuild30
2 files changed, 99 insertions, 0 deletions
diff --git a/kde-apps/libkleo/files/libkleo-4.4.2016.01-install_headers.patch b/kde-apps/libkleo/files/libkleo-4.4.2016.01-install_headers.patch
new file mode 100644
index 000000000000..75e60fb60652
--- /dev/null
+++ b/kde-apps/libkleo/files/libkleo-4.4.2016.01-install_headers.patch
@@ -0,0 +1,69 @@
+Install headers needed by Kopete's cryptography plugin.
+
+--- /libkleo/CMakeLists.txt
++++ /libkleo/CMakeLists.txt
+@@ -118,3 +118,64 @@
+ install(TARGETS kleo ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+ install ( FILES libkleopatrarc.desktop DESTINATION ${CONFIG_INSTALL_DIR} RENAME libkleopatrarc )
++
++install( FILES
++ kleo/abstractimportjob.h
++ kleo/adduseridjob.h
++ kleo/changeexpiryjob.h
++ kleo/changeownertrustjob.h
++ kleo/cryptobackend.h
++ kleo/cryptobackendfactory.h
++ kleo/cryptoconfig.h
++ kleo/cryptplug.h
++ kleo/cryptplugfactory.h
++ kleo/cryptplugwrapper.h
++ kleo/cryptplugwrapperlist.h
++ kleo/decryptjob.h
++ kleo/decryptverifyjob.h
++ kleo/deletejob.h
++ kleo/dn.h
++ kleo/downloadjob.h
++ kleo/encryptjob.h
++ kleo/enum.h
++ kleo/exportjob.h
++ kleo/hierarchicalkeylistjob.h
++ kleo/importfromkeyserverjob.h
++ kleo/importjob.h
++ kleo/job.h
++ kleo/kconfigbasedkeyfilter.h
++ kleo/keyfilter.h
++ kleo/keyfiltermanager.h
++ kleo/keygenerationjob.h
++ kleo/keylistjob.h
++ kleo/kleo_export.h
++ kleo/multideletejob.h
++ kleo/oidmap.h
++ kleo/refreshkeysjob.h
++ kleo/signencryptjob.h
++ kleo/signjob.h
++ kleo/signkeyjob.h
++ kleo/specialjob.h
++ kleo/verifydetachedjob.h
++ kleo/verifyopaquejob.h
++ DESTINATION ${INCLUDE_INSTALL_DIR}/kleo COMPONENT Devel)
++
++install ( FILES
++ ui/adddirectoryservicedialogimpl.h
++ ui/backendconfigwidget.h
++ ui/cryptoconfigdialog.h
++ ui/cryptoconfigmodule.h
++ ui/cryptoconfigmodule_p.h
++ ui/directoryserviceswidget.h
++ ui/dnattributeorderconfigwidget.h
++ ui/filenamerequester.h
++ ui/kdhorizontalline.h
++ ui/keyapprovaldialog.h
++ ui/keylistview.h
++ ui/keyrequester.h
++ ui/keyselectiondialog.h
++ ui/messagebox.h
++ ui/messagebox_p.h
++ ui/progressbar.h
++ ui/progressdialog.h
++ DESTINATION ${INCLUDE_INSTALL_DIR}/kleo/ui COMPONENT Devel)
diff --git a/kde-apps/libkleo/libkleo-4.4.2016.01-r1.ebuild b/kde-apps/libkleo/libkleo-4.4.2016.01-r1.ebuild
new file mode 100644
index 000000000000..e999bb5fd75e
--- /dev/null
+++ b/kde-apps/libkleo/libkleo-4.4.2016.01-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE library for encryption handling"
+HOMEPAGE="https://launchpad.net/~pali/+archive/ubuntu/kdepim-noakonadi"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ $(add_kdeapps_dep kdepimlibs '' 4.6)
+"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+"
+
+KMSAVELIBS="true"
+KMEXTRACTONLY="kleopatra/"
+
+PATCHES=( "${FILESDIR}/${P}-install_headers.patch" )
+
+src_prepare() {
+ append-cxxflags -std=c++11
+ kde4-meta_src_prepare
+}