summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 01:05:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 14:09:23 +0200
commitdfd9e0a3bf759bbd97b5528d217d60c7fe4a765f (patch)
tree8934bd04af30dd24c861648deec4fc5ce2bf24e2 /kde-apps/dolphin
parentapp-misc/mc: drop old (diff)
downloadgentoo-dfd9e0a3bf759bbd97b5528d217d60c7fe4a765f.tar.gz
gentoo-dfd9e0a3bf759bbd97b5528d217d60c7fe4a765f.tar.bz2
gentoo-dfd9e0a3bf759bbd97b5528d217d60c7fe4a765f.zip
kde-apps/dolphin: Fix startup error message
This is a downstream hack for now. KDE-bug: https://bugs.kde.org/show_bug.cgi?id=435586 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/dolphin-20.12.3-r1.ebuild2
-rw-r--r--kde-apps/dolphin/dolphin-21.04.0.ebuild3
-rw-r--r--kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch23
3 files changed, 28 insertions, 0 deletions
diff --git a/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild b/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
index 7f9f2d90c9af..84ed6041e315 100644
--- a/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
+++ b/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
@@ -64,6 +64,8 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${P}-fix-session-restore-w-o-tabs.patch" # KDE-bug 434911
+ # TODO: Downstream hack, track upstream bug for better solution
+ "${FILESDIR}/${PN}-21.04.0-fix-no-semantic-desktop.patch" # KDE-bug 435586
)
src_configure() {
diff --git a/kde-apps/dolphin/dolphin-21.04.0.ebuild b/kde-apps/dolphin/dolphin-21.04.0.ebuild
index 2f5121e83267..c9439d4dddc3 100644
--- a/kde-apps/dolphin/dolphin-21.04.0.ebuild
+++ b/kde-apps/dolphin/dolphin-21.04.0.ebuild
@@ -62,6 +62,9 @@ RDEPEND="${DEPEND}
>=kde-apps/kio-extras-${PVCUT}:5
"
+# TODO: Downstream hack, track upstream bug for better solution
+PATCHES=( "${FILESDIR}/${P}-fix-no-semantic-desktop.patch" ) # KDE-bug 435586
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
diff --git a/kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch b/kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch
new file mode 100644
index 000000000000..4f97a53c5230
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch
@@ -0,0 +1,23 @@
+diff --git a/src/search/dolphinfacetswidget.cpp b/src/search/dolphinfacetswidget.cpp
+index d52d146a8..9f0078631 100644
+--- a/src/search/dolphinfacetswidget.cpp
++++ b/src/search/dolphinfacetswidget.cpp
+@@ -7,6 +7,8 @@
+
+ #include "dolphinfacetswidget.h"
+
++#include <config-baloo.h>
++
+ #include <KLocalizedString>
+
+ #include <QComboBox>
+@@ -257,7 +259,9 @@ void DolphinFacetsWidget::updateTagsSelector()
+ void DolphinFacetsWidget::updateTagsMenu()
+ {
+ updateTagsMenuItems({}, {});
++#ifdef HAVE_BALOO
+ m_tagsLister.openUrl(QUrl(QStringLiteral("tags:/")), KCoreDirLister::OpenUrlFlag::Reload);
++#endif
+ }
+
+ void DolphinFacetsWidget::updateTagsMenuItems(const QUrl&, const KFileItemList& items)