summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-09 20:09:53 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-09 20:26:05 +0100
commit40cce1797befe332a79f52bba80e3d144297ceff (patch)
treea466705e4322739fd5dc6f2501eb401b5fe02385 /kde-apps/akonadi
parentdev-db/percona-server: Security cleanup (bug #612150) (diff)
downloadgentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.gz
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.bz2
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.zip
kde-apps: Version bump KDE Applications 16.12.3
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'kde-apps/akonadi')
-rw-r--r--kde-apps/akonadi/Manifest1
-rw-r--r--kde-apps/akonadi/akonadi-16.12.3.ebuild125
-rw-r--r--kde-apps/akonadi/files/akonadi-16.12.3-akonadixml.patch22
3 files changed, 148 insertions, 0 deletions
diff --git a/kde-apps/akonadi/Manifest b/kde-apps/akonadi/Manifest
index 866c3712bd69..25fa67474a97 100644
--- a/kde-apps/akonadi/Manifest
+++ b/kde-apps/akonadi/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-1.13.1_pre20160203.tar.gz 384556 SHA256 4243b32e529be6aadc38dc4463cb6e7cede9442c05cfc04ba679dde28f37aa96 SHA512 0ef8213f504ad1e500a2c1ce19a7575cd1fd8b7ffc7e5fb0bd2437639d8c458c47bbfea7734fcd3e200136a661331dde32af0b064f0b25d324138ce6e35d15f3 WHIRLPOOL 69eff1889a19f8d5714d7e71a106871172cd25c651ea30046ab81270cf7e46c7a1983cf20fd8d5fd8ad243d70e881be705d57b0b93b54248d086e7b253a4873a
DIST akonadi-16.12.2.tar.xz 1036664 SHA256 bf40309f36bea813341187f72d55546eeabe0538657ea9a665a3156393514ab3 SHA512 b5ae74bc47a3bf375b1c4d3b77a4e563d82409d32aca71da798bc021e81304b73a733095a8379d87765baec8190a73f45c29d2a9442a41e8faace95b6fb49cee WHIRLPOOL 60f1b32a84f874f61aaa4a19f1fd14884b63d103985ae5b8d809a42b64eae8e30b2f625e82c7788e001211fa5235aa1b1be1f86a7003a918b11553a75d9fe038
+DIST akonadi-16.12.3.tar.xz 1037568 SHA256 fc48a200c27331d5a9ac6bfb8d7d61f3c4240f133bb23c996c78493f24644b03 SHA512 b1e02f80d11aa6f6d116bfbd963dee952ad03acbdf451b3cd0f8ca4d0037cea9afcd3723b7743bf5beeeb8d0db865094c0178be82e1a74deddaa45834f57c77f WHIRLPOOL b14b453ebfee66d4bb3ab6806406765c74e6f0edd5b4d40346c038d29330afa2efbcb8794564c9a0bce0e693ec04ab540580467411ae869b3c30263d6ed69f7e
diff --git a/kde-apps/akonadi/akonadi-16.12.3.ebuild b/kde-apps/akonadi/akonadi-16.12.3.ebuild
new file mode 100644
index 000000000000..533ef6fd0b93
--- /dev/null
+++ b/kde-apps/akonadi/akonadi-16.12.3.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Storage service for PIM data and libraries for PIM apps"
+HOMEPAGE="https://pim.kde.org/akonadi"
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="LGPL-2.1+"
+IUSE="+mysql postgres sqlite tools xml"
+
+REQUIRED_USE="|| ( sqlite mysql postgres ) test? ( tools )"
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsql 'mysql?,postgres?')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ x11-misc/shared-mime-info
+ sqlite? ( dev-db/sqlite:3 )
+ xml? ( dev-libs/libxml2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ dev-libs/libxslt
+ test? ( sys-apps/dbus )
+"
+RDEPEND="${COMMON_DEPEND}
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ !kde-apps/kdepimlibs
+"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-16.12.0-mysql56-crash.patch"
+ "${FILESDIR}/${PN}-16.12.1-revert-abs-path.patch"
+ "${FILESDIR}/${PN}-16.12.1-rename-header.patch"
+ "${FILESDIR}/${PN}-16.12.3-akonadixml.patch"
+)
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about MySQL is recommend by upstream
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "In particular, kde-apps/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
+ -DBUILD_TOOLS=$(usex tools)
+ $(cmake-utils_use_find_package xml LibXml2)
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ kde5_src_install
+}
+
+pkg_postinst() {
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/kde-apps/akonadi/files/akonadi-16.12.3-akonadixml.patch b/kde-apps/akonadi/files/akonadi-16.12.3-akonadixml.patch
new file mode 100644
index 000000000000..6acd5b86dc8f
--- /dev/null
+++ b/kde-apps/akonadi/files/akonadi-16.12.3-akonadixml.patch
@@ -0,0 +1,22 @@
+commit 2fe8bf8b73b9f5f5d19c87099b71a71f2595e70f
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sat Feb 11 21:29:05 2017 +0100
+
+ Build akonadixml unconditionally
+
+ It makes more sense now that akonadiconsole depends on it.
+
+ REVIEW: 129941
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 4141947..4e79dc0 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -16,6 +16,4 @@ add_subdirectory(core)
+ add_subdirectory(agentbase)
+ add_subdirectory(widgets)
+ add_subdirectory(selftest)
+-if(BUILD_TOOLS)
+- add_subdirectory(xml)
+-endif()
++add_subdirectory(xml)