summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-02-20 21:24:37 -0300
committerPacho Ramos <pacho@gentoo.org>2024-11-08 20:44:29 +0100
commit7448e7251b49d320e5138853e8736f9644fa89e6 (patch)
treeed8b73c68fdaeb79557b3faaa71c5e8d355c85c4 /gui-libs/libpanel
parentsci-chemistry/chemex: drop 2024.05.2-r1 (diff)
downloadgentoo-7448e7251b49d320e5138853e8736f9644fa89e6.tar.gz
gentoo-7448e7251b49d320e5138853e8736f9644fa89e6.tar.bz2
gentoo-7448e7251b49d320e5138853e8736f9644fa89e6.zip
gui-libs/libpanel: Bump to 1.6.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gui-libs/libpanel')
-rw-r--r--gui-libs/libpanel/Manifest1
-rw-r--r--gui-libs/libpanel/libpanel-1.6.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gui-libs/libpanel/Manifest b/gui-libs/libpanel/Manifest
index fc3e21ec7f97..8624f70d6c20 100644
--- a/gui-libs/libpanel/Manifest
+++ b/gui-libs/libpanel/Manifest
@@ -1 +1,2 @@
DIST libpanel-1.4.1.tar.xz 160208 BLAKE2B 01f4a8a77ac4c6d26c05eea9fda88461d8c688f0c80cbb3cc119260814c3766989b6eb9d7893729eca2239670b3a9d089000b5f1185b7650b0bdcf604c7195cf SHA512 44efb5dd29c83471acd64701320b2cb6057c6165c5b7602d2e0b7a40690a493c42ff3b28bc7924569d81c6e6a8ddc784b0df1c351919924807d61c9fdd2a4263
+DIST libpanel-1.6.0.tar.xz 162584 BLAKE2B 1da55961a9f993d2d31a2dab51a687b7b0fe72aa02e0f045bd361db2b67ae3c07dde28b8df031d40b8da73009f721e19eae4a0e4c37c34c8dac4704ffbdd06a9 SHA512 e836941edcff416c5205d5c97b3c9d20b28d7cb7148b342f34dd768b93e3c317b1aa9b97435602c00c3bdbe763d56b112936a8d15117b448fa8bd0fd19204cfb
diff --git a/gui-libs/libpanel/libpanel-1.6.0.ebuild b/gui-libs/libpanel/libpanel-1.6.0.ebuild
new file mode 100644
index 000000000000..ff73c6e83733
--- /dev/null
+++ b/gui-libs/libpanel/libpanel-1.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="A dock/panel library for GTK 4"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libpanel"
+
+LICENSE="LGPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="examples gtk-doc +introspection +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.75:2
+ >=gui-libs/gtk-4.8:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples install-examples)
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc docs)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir "${ED}"/usr/share/gtk-doc || die
+ mv "${ED}"/usr/share/doc/panel-1.0 "${ED}"/usr/share/gtk-doc/ || die
+ fi
+}