summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ruhier <aruhier@mailbox.org>2024-05-06 16:25:46 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-08 18:45:53 +0300
commite025198890863e4a5e1b0a9441df24ccd3115d7f (patch)
treec0b28d116ec2f71e9ad1b9c8cbefdf29fe6b09ef /gui-apps
parentgui-apps/wmenu: add 0.1.8 (diff)
downloadgentoo-e025198890863e4a5e1b0a9441df24ccd3115d7f.tar.gz
gentoo-e025198890863e4a5e1b0a9441df24ccd3115d7f.tar.bz2
gentoo-e025198890863e4a5e1b0a9441df24ccd3115d7f.zip
gui-apps/waybar: add 0.10.3
Signed-off-by: Anthony Ruhier <aruhier@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/36585 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/Manifest1
-rw-r--r--gui-apps/waybar/waybar-0.10.3.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
index 197aa202e1cf..c26823c01a22 100644
--- a/gui-apps/waybar/Manifest
+++ b/gui-apps/waybar/Manifest
@@ -1,3 +1,4 @@
DIST waybar-0.10.0.tar.gz 297669 BLAKE2B f27a61662444cb0d91ecb5c860271939ba81813af4d005a3297f9996fab5edd54df2e4a126aa33edf9049e2d91d301a03f6352e25eb9c86ffb003b0b238e9015 SHA512 89d5ee6fb52438aadfcad8929940b2f2c4a469f7f07331fa5dff77997e1dedb6b3b020c2c2f809687993a7da2571b9f08768e92172d08bfb3d4b66db2d20d61f
+DIST waybar-0.10.3.tar.gz 301886 BLAKE2B 0ef1cf82cc9f374c756724c389a045d2d9e26a5403eeb527ab0885d89d6030bea74aa5c299f8f865c244524c485a90ad3fee071968d21ff728c1f46f75f637b4 SHA512 2e90007056b79bccad06902db2e8b6f25103bb7c86736cb0b7dc260795bc4a1b5db7a7b8a4bebe9169f0590585fd6b170193cf8aa5437d69bab0f78d66922084
DIST waybar-0.9.22.tar.gz 255896 BLAKE2B 51ad09f401a871f4b17552c85b838be950d52ebab6b2230619cfa95acbbc2f6cbc5ae1cb1228ca4207052397090f9fd4470388808cc81954b59c16f5cc25ed9e SHA512 0cd2d4fdf51528d1246da756ec1d4be5dd897208f4ec1aef5ab2d2801ab72145bcccef68fa62e55f0b1bb9913d471ce5c748de97f9d785d55c06a5f6717c9849
DIST waybar-0.9.24.tar.gz 275416 BLAKE2B 15774a78f2f7bb85d497e7f80a968b775bb42d285d0950e8e384962c6b947ea895eea2b30c0aba7ca671595ce59acd65e66cf8b67f2478ecad7564de50e4bfe6 SHA512 13177fbc2c537cd903294ab708ae46307a785c524cbdbca06abe869af1f7ccc866ce38b6fbc2b3769cd95f458c46296b4c88ee927cabe890692e78b999143f0e
diff --git a/gui-apps/waybar/waybar-0.10.3.ebuild b/gui-apps/waybar/waybar-0.10.3.ebuild
new file mode 100644
index 000000000000..0cb73fc0bd3b
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.10.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="evdev experimental jack +libinput +logind mpd mpris network pipewire pulseaudio sndio systemd test tray +udev upower wifi"
+REQUIRED_USE="
+ mpris? ( logind )
+ upower? ( logind )
+"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=app-text/scdoc-1.9.2
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-8.1.1:=
+ >=dev-libs/spdlog-1.10.0:=
+ dev-libs/date:=
+ dev-libs/wayland
+ gui-libs/gtk-layer-shell
+ gui-libs/wlroots:=
+ x11-libs/gtk+:3[wayland]
+ x11-libs/libxkbcommon
+ evdev? ( dev-libs/libevdev:= )
+ jack? ( virtual/jack )
+ libinput? ( dev-libs/libinput:= )
+ logind? (
+ || ( sys-apps/systemd
+ sys-auth/elogind )
+ )
+ mpd? ( media-libs/libmpdclient )
+ mpris? ( >=media-sound/playerctl-2 )
+ network? ( dev-libs/libnl:3 )
+ pipewire? ( media-video/wireplumber:0/0.5 )
+ pulseaudio? ( media-libs/libpulse )
+ sndio? ( media-sound/sndio:= )
+ systemd? ( sys-apps/systemd:= )
+ tray? (
+ dev-libs/libdbusmenu[gtk3]
+ dev-libs/libayatana-appindicator
+ )
+ udev? ( virtual/libudev:= )
+ upower? ( sys-power/upower )
+ wifi? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+ test? ( dev-cpp/catch:0 )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dcava=disabled
+ $(meson_feature evdev libevdev)
+ $(meson_feature jack)
+ $(meson_feature libinput)
+ $(meson_feature logind)
+ $(meson_feature mpd)
+ $(meson_feature mpris)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature pipewire wireplumber)
+ $(meson_feature pipewire)
+ $(meson_feature sndio)
+ $(meson_feature systemd)
+ $(meson_feature test tests)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ $(meson_feature upower upower_glib)
+ $(meson_feature wifi rfkill)
+ $(meson_use experimental)
+ )
+ meson_src_configure
+}