summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-12-21 09:21:18 +0200
committerBen Kohler <bkohler@gentoo.org>2024-01-19 07:54:58 -0600
commitc38f925beb2ccae88e0053c1645413d985fa9578 (patch)
treecb2b809d2512748fbe5ee24eb31b602ddbe2cd7c /gui-apps
parentgui-apps/wcm: add 0.8.0 (diff)
downloadgentoo-c38f925beb2ccae88e0053c1645413d985fa9578.tar.gz
gentoo-c38f925beb2ccae88e0053c1645413d985fa9578.tar.bz2
gentoo-c38f925beb2ccae88e0053c1645413d985fa9578.zip
gui-apps/wcm: update live ebuild
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild32
1 files changed, 25 insertions, 7 deletions
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index d91c7aa57b64..e1cf56f1e071 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -11,24 +11,42 @@ HOMEPAGE="https://github.com/WayfireWM/wcm"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
-DEPEND="
+RESTRIC="test" # no tests
+
+CDEPEND="
dev-libs/libevdev
dev-libs/libxml2
+ dev-libs/wayland
dev-cpp/gtkmm:3.0[wayland]
- >=gui-wm/wayfire-${PV%.*}
+ gui-apps/wf-shell:${SLOT}
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
+ x11-libs/libxkbcommon
"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
+RDEPEND="${CDEPEND}"
+DEPEND="
+ ${CDEPEND}
dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
virtual/pkgconfig
"
+
+src_configure() {
+ local emesonargs=(
+ -Dwf_shell=enabled
+ -Denable_wdisplays=true
+ )
+
+ meson_src_configure
+}