summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-18 19:07:11 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-18 19:08:52 +0100
commitad2ea32d677078052d679f9815cc4055ec8a8ced (patch)
tree11d05bf98adc838001997b2cf7acfd00c886228e /gnome-extra
parentdev-vcs/git-bzr-ng: python-single-r1, EAPI=6 (diff)
downloadgentoo-ad2ea32d677078052d679f9815cc4055ec8a8ced.tar.gz
gentoo-ad2ea32d677078052d679f9815cc4055ec8a8ced.tar.bz2
gentoo-ad2ea32d677078052d679f9815cc4055ec8a8ced.zip
gnome-extra/cameramonitor: python-single-r1, EAPI=6
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cameramonitor/cameramonitor-0.3.2-r1.ebuild27
-rw-r--r--gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild51
2 files changed, 27 insertions, 51 deletions
diff --git a/gnome-extra/cameramonitor/cameramonitor-0.3.2-r1.ebuild b/gnome-extra/cameramonitor/cameramonitor-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..bb43b81dda83
--- /dev/null
+++ b/gnome-extra/cameramonitor/cameramonitor-0.3.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# eautoreconf needed to fix old Python m4 code
+GNOME2_EAUTORECONF=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Local Webcam monitoring in system tray"
+HOMEPAGE="https://launchpad.net/cameramonitor"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/gconf-python:2[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild b/gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild
deleted file mode 100644
index 842ab77edfbf..000000000000
--- a/gnome-extra/cameramonitor/cameramonitor-0.3.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-PYTHON_DEPEND="2"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit gnome2 python autotools
-
-DESCRIPTION="Local Webcam monitoring in system tray"
-HOMEPAGE="https://launchpad.net/cameramonitor"
-SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/gconf-python:2
- dev-python/notify-python
- dev-python/pyinotify
- dev-python/dbus-python"
-
-DEPEND="${RDEPEND}"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- python_clean_py-compile_files
-
- eautoreconf
-
- gnome2_src_prepare
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_mod_optimize cameramonitor
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup cameramonitor
-}