summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-04-18 16:09:35 +0200
committerPacho Ramos <pacho@gentoo.org>2023-04-18 16:17:31 +0200
commit9f46da3bd977ba9124310da5236a4dd1499b958f (patch)
tree2f0c20a3868269db3ab5212bc08f7843041e8f0d /gnome-extra
parentgnome-extra/gnome-shell-extension-desktop-icons-ng: add 47.0.2 (diff)
downloadgentoo-9f46da3bd977ba9124310da5236a4dd1499b958f.tar.gz
gentoo-9f46da3bd977ba9124310da5236a4dd1499b958f.tar.bz2
gentoo-9f46da3bd977ba9124310da5236a4dd1499b958f.zip
gnome-extra/gnome-shell-extension-weather-in-the-clock: Support gnome 44
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild
new file mode 100644
index 000000000000..d3210bf84483
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Display the current weather in the clock"
+HOMEPAGE="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock"
+COMMIT="38ba36090961a37260215ae04f4a7e0a1377da95"
+SRC_URI="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+ gnome-extra/gnome-weather
+"
+DEPEND=""
+BDEPEND=""
+
+extension_uuid="weatherintheclock@JasonLG1979.github.io"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ # https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/issues/30
+ sed -i -e 's/"43"/"43", "44"/' \
+ "${extension_uuid}"/metadata.json || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/gnome-shell/extensions/
+ doins -r "${extension_uuid}"
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}